error in adding multiple instances

We are using an EC2 instance to monitor RDS aurora clusters and the instance class of EC2 is t2.large. I’ve been added 10 clusters out of that, 7 are working fine. The rest are showing running state as NO. I haven’t get any error while adding but seeing that running state as NO. I removed them and tried to add again, still the same. what am I missing in this process?

Hi govindareddy20,

the first idea - network connectivity or firewall settings.

  • are all clusters located in the one region?
  • are all clusters located in the one availability zone?
  • are all clusters have the same VPC ID?
  • are all clusters located in the same Subnet ID?
  • can you check security groups?

Hi Mykola,
They are all under same region, availability zone, VPC, subnets and using same security group.

Hi govindareddy20,

can you make screenshot what exactly is not working?

Below are the clusters I added, We can see from the bottom which the running state showing as “NO”. When I’m running add mysql command, the output showing as OK for linux:metrics, mysql:metrics and mysql:queries. When I see the list, Running state showing as NO. Though, I can see that cluster in QAN window but it is not showing up in Grafana. The rest are all working fine in both QAN and Grafana.

linux:metrics abcde 42000 YES
mysql:metrics bcdef 42002 YES
mysql:metrics cdefg 42003 YES
mysql:metrics defgh 42004 YES
mysql:metrics efghi 42005 YES
mysql:metrics fghij 42006 YES
mysql:metrics ghijk 42007 YES
mysql:metrics hijkl 42008 YES
mysql:metrics ijklm 42009 YES
mysql:metrics jklmn 42010 YES
mysql:metrics klmno 42011 NO
mysql:metrics lmnop 42012 YES

Are aurora instances (not clusters) user the same “Parameter Groups” ?

Can you try to remove broken instance and add it again?

sudo pmm-admin remove mysql:metrics klmno 
sudo pmm-admin add mysql:metrics --host --user pmm --password pass klmno

can you check instance credentials before add?

mysql -h -u pmm -p pass

I tried to remove and add, but still the same after adding. The user is same for all instances I added. If the credentials are incorrect, It should threw an error while adding but it shows that all metrics are OK.

pmm-admin checks credentials during first add, but they can be changed.

Are aurora instances (not clusters) use the same “Parameter Groups” in AWS?

it is hard to get down service after after remove-adding…
can you start service manually?

pmm-admin start mysql:metrics klmno

That’s working, what might be the issue stopping this here?

hard to guess :frowning:
systemd glitch, selinux, not enough RAM, reboot etc

Thanks Mykola…!!!