I need to use PMM with RDS. I have an image that was created by my devops following the docker instructions (the AMI image would not connect to the RDS).
Then I go to this page:

I’ve turned on P_S and I created the pmm mysql user.
But when I go to the next command:
sudo pmm-admin add mysql:metrics --host …
And of course there is no pmm-admin software. I installed it on the host server of the docker container and tried again.
pmm-admin add …
I’m told to run pmm-admin config.
I have verified the server is running and I can see the OS metrics for the pmm-server. But I can not configure the RDS. They are in the same vpc and vpc subnet.

I’ve done from another ec2, pmm-server docker container and pmm-server that holds the docker container:
curl http:///prometheus/

It’s just not clear how I tell the pmm-server to take metrics on an RDS server…

Please run

pmm-admin info


pmm-admin check-network

on the host you use to connect to the RDS instance and where PMM client is installed.

X.X.X.X = PMM server IP
pmm-admin info:

pmm-admin 1.1.3

PMM Server | X.X.X.X
Client Name | ip-X-X-X-X
Client Address | X.X.X.X

Service Manager | linux-systemd

Go Version | 1.8
Runtime Info | linux/amd64

PMM Network Status

Server Address | X.X.X.X
Client Address | X.X.X.X

  • System Time
    PMM Server | 2017-05-19 22:16:25 +0000 GMT
    PMM Client | 2017-05-19 22:16:30 +0000 UTC
    PMM Client to PMM Server Time Drift | OK

  • Connection: Client --> Server


Consul API OK
Prometheus API OK
Query Analytics API OK

Connection duration | 165.281µs
Request duration | 20.396741ms
Full round trip | 20.562022ms

  • Connection: Client <-- Server


mysql:metrics mydb1.rds X.X.X.X:42002 DOWN YES -
mysql:metrics mydb2.rds X.X.X.X:42003 DOWN YES -
mysql:metrics mydb3.rds X.X.X.X:42004 DOWN YES -

When an endpoint is down it may indicate that the corresponding service is stopped (run ‘pmm-admin list’ to verify).

If it’s running, check out the logs /var/log/pmm-*.log

When all endpoints are down but ‘pmm-admin list’ shows they are up and no errors in the logs,
check the firewall settings whether this system allows incoming connections from server to address:port in question.

Also you can check the endpoint status by the URL: http://X.X.X.X/prometheus/targets

From the PMM server I can run a mysql -h $HOST to each of the mydb hosts.
There is data in https://X.X.X.X:42002/42002/metrics-hr (and lr & mr) and:

mysql_exporter_hr_scrapes_total = # that increments
mysql_exporter_hr_last_scrape_error 0

https://X.X.X.X/prometheus/targets shows EVERYTHING down including the localhost:9100/metrics
http://localhost:9090/prometheus/metrics UP

I came in this am and the prometheus/metrics is down on the local host.

and it’s down again… I’m not sure what is going on with PMM ?It’s ONLY the mysql:metrics. The mysql:queries is working.

I rebooted the instance, started the docker container and metrics are back. It may be that the instance was too small for 3 RDS servers (two were very small) I removed all but the most important and purged the other data. I did this for BOTH mysql:metrics and mysql:queries. However the queries still show up for the 2 dbs I removed. Now the prometheus/targets are showing up for the one db I want & down for the other two. (not sure how to remove them?)

Turns out the old PC standard worked. REBOOT, restart.

Thanks for your all your help. I was able to add a mongodb client (I admit I had to use the forums) and now have both MySQL AND MongoDB. I LOVE PMM!