The deployment keep using PXC 8.0.25-15.1

Hello there,
I am provisioning MySql 5.7 with helm. but it keeps installing PXC 8.0.25-15.1. it looks like the version number is hardcoded.

Please advise.

pxc:
  size: 3
  image:
    repository: percona/percona-xtradb-cluster
    tag: 5.7.35-31.53

Snippet from Operator Log:

{"level":"info","ts":1652499431.1839664,"caller":"pxc/version.go:159","msg":"set PXC version to 8.0.25-15.1"}
{"level":"info","ts":1652499431.1842544,"caller":"pxc/version.go:168","msg":"set Backup version to 8.0.25"}
{"level":"info","ts":1652499431.1842608,"caller":"pxc/version.go:195","msg":"set HAProxy version to 2.3.15"}

Arthur

1 Like

Hi @A_Niu !
I believe your cluster is getting the desired version from our version service so you need to disable it like so:

  upgradeOptions:
    versionServiceEndpoint: https://check.percona.com
    apply: disabled
    schedule: "0 4 * * *"

upgradeOptions.apply: disabled is important here.
One thing important if you will have more questions is since it seems you are using our Kubernetes operator, better use “Percona Operator for MySQL” category in the forum.

1 Like

Thanks, @tplavcic

It does stop the upgrading. but keep getting below error, no matter I tried version 8 or 5.7

Readiness probe failed: ERROR 2003 (HY000): Can't connect to MySQL server on '10.41.2.67' (111) + [[ '' == \P\r\i\m\a\r\y ]] + exit 1
1 Like

The Percona helm chart has problem to support 5.7 on Kubernetes later than 1.21.
Same code works in another Kubernetes cluster (version: 1.20.11).

W0516 21:24:14.237035       1 warnings.go:67] policy/v1beta1 PodDisruptionBudget is deprecated in v1.21+, unavailable in v1.25+; use policy/v1 PodDisruptionBudget

1 Like