libmysqlclient - no such file, need your help..


I’m using THE latest ubuntu, percona server 5.6 for sql server…

I wan’t to run a few game servers on my dedicated box… (GTA SA-MP)
This game is using sql plugins… the one I wanted to use gives me this error.

Failed ( cannot open shared object file: No such file or directory)

I don’t have any libmysqlclient .so files…

And I have trouble getting them working.

Where and how would I get the right files for this error?
Where would I need to put them?

I Would like to continue with percona sql… but I need to get it working.

Also libmysqlclient 15, 16, 18?

If you have any info, I would appreciate it!


Can you provide the exact Ubuntu version? most probably it should be resolved by installing libmysqlclient-dev package.
sudo apt-get install libmysqlclient-dev


Distributor ID: Ubuntu
Description: Ubuntu Trusty Tahr (development branch)
Release: 14.04
Codename: trusty

Hi, Have you tried to install [COLOR=#252C2F]libmysqlclient-dev and check? [COLOR=#252C2F]

I tried everything…

finally I found the correct libmysqldclient file version from another forum and copied it to /usr/lib …

none of the standard commands worked.

This one is now solved for me.