innobackupex extremely slow or infinitely looping


I’ve installed percona server 5.5 and xtrabackup 2.0.7 and tried creating a backup of my 100 GB database (size of files in /var/lib/mysql/DBNAME).

I ran the following command:

innobackupex --user=USER --password=PW /raid/backup/mysql

which seems to start the following process:

xtrabackup_55 --defaults-group=mysqld --backup --suspend-at-end --target-dir=/raid/backup/mysql/2013-05-27_15-01-36 --tmpdir=/tmp

This has been running for 48 hours and keeps printing the following lines with increasing numbers:

>> log scanned up to (36608838935)
>> log scanned up to (36608867811)
>> log scanned up to (36608897762)

So I decided to kill the process, as something is probably wrong.

I then called

innobackupex --user=USER --password=PW --apply-log /raid/backup/mysql/2013-05-27_15-01-36/

This command also has been running for several hours now, it’s at 68% now.

Is it normal this is taking so long / am I doing something wrong? mysqldump takes only about 2 hours to complete. Why would I use xtrabackup?



@smuellerus, If you killed the backup and still try to apply log on it, something would definitely be wrong. However, the backup taking too long in itself may be indicative of another problem.

During that time, are these number incrementing? If so the backup is active - though 48hrs is not reasonable for 100G.

log scanned up to (36608897762)

Can you check that there are no storage problems on the destination partition? i.e. dmesg, syslog etc

I have exactly same problem when I try to take a “SLAVE” backup with 2.1.x version of the xtrabackup? Database size is about ~100G.
MySQL is 5.5.31 on Debian (64-bit)