How PMM node and service match


[Detailed description of the issue or question]

In PMM, node and service don’t give each other an option to identify, how do they connect to each other?

If there is one node and one service in one server, they identify each other well, but if there are two nodes and two services in one server, I don’t know how to connect each node and service.

Steps to Reproduce:

[Step-by-step instructions on how to reproduce the issue, including any specific settings or configurations]


[Insert the version number of the software]



[If applicable, include any relevant log files or error messages]

node install command

pmm-agent setup --config-file=/usr/local/percona/pmm2/config/pmm-agent.yaml --server-address=[server-address] --server-insecure-tls --server-username=admin --server-password=admin --paths-tempdir=/usr/local/percona/pmm2/tmp --paths-base=/usr/local/percona/pmm2 [LOCAL_IP] generic [PMM_NODE_NAME]

service add command

pmm-admin add mysql --username=pmm --password=pmm --tls-skip-verify --query-source=perfschema --agent-password=pmm --service-name=[PMM_SERVICE_NAME] --host=[LOCAL_IP] --port=3306

Expected Result:

[What the user expected to see or happen before the issue occurred]

Actual Result:

[What actually happened when the user encountered the issue]

Additional Information:

[Include any additional information that could be helpful to diagnose the issue, such as browser or device information]

Hi @pmmChobo,

You can identify individual service by assigning them unique name while adding them.
I see you have noted the command that has --service-name flag.
I believe on the same line you can add the node names probably two containers on a server?

pmm-admin add mysql --username=pmm --password=pmm --service-name=mysql1
pmm-admin add mysql --username=pmm --password=pmm --service-name=mysql2
pmm-admin add mysql --username=pmm --password=pmm --service-name=mysqlX