Access Denied issue

While trying to access the settings in PMM server i am getting the attached errors.
I tried restarting the docker conainer where PMM server resides.
Checked the var/lib/docker and there is sufficient space as well.

1 Like

Hi @velumal,

It looks like you are using a user with “Viewer” or “Editor” role.
The Setting page is limited to the “Admin” role.

1 Like

You were right. My id was restricted to viewer. I tried changing the role to Admin but it didn’t work.
I tried creating a new org named Test Org with my id role as admin.
After creating the new org, i logged in using the admin credentials i cannot see the default dashboards and PMM clients which were getting monitored earlier.

This is what i am seeing now.

I don’t see any of my MongoDB, Postgres & MySQL server dashboards which were present earlier. Dashboard section is empty now.

How do i resolve this issue… is there a way to revert the changes ?

Appreciate your help.


1 Like

I can see the PMM clients inventory list though.

But not the dashboards for them. :frowning:

1 Like

You should switch to “Main Org.” organization.

1 Like

Apologies for my delayed response… I did this and was able to see the original dashboards.
As i am learning through the tool i am finding it more & more interesting.
Appreciate your help on this :slight_smile:

1 Like