Unable to install Percona MySQL 5.7.x software on Debian 10 buster


I am unable to install Percona MySQL 5.7.x software “Client, Common, etc” on Debian 10 buster.

I have used these command a bunch of times on different servers, but now this is failing?

apt install gnupg2
wget https://repo.percona.com/apt/percona-release_latest.$(lsb_release -sc)_all.deb
dpkg -i percona-release_latest.$(lsb_release -sc)_all.deb
apt update
apt-ge install percona-server-common-5.7 percona-server-client-5.7

percona-release show
The following repositories are enabled on your system:
<*> All done!

dpkg -l | grep -i mysql
ii mysql-common 5.8+1.0.5 all MySQL database common files, e.g. /etc/mysql/my.cnf
ii php7.3-mysql 7.3.33-1+0~20211119.91+debian10~1.gbp618351 amd64 MySQL module for PHP

percona-release setup ps80
Specified repository does not exist: Percona Repo


1 Like

Hi @jbiancot , welcome back to the Percona forums!

I’m not on a debian 10 installation but perhaps you could try the command percona-release setup ps-80 (note the hypen)

1 Like

Hi @jbiancot
I tried to reproduce your issue but without success. Everything works well and I installed requested packages.
Most probably it is because there is a typo in one of your commands apt-ge instead of apt-get
please try apt-get install percona-server-common-5.7 percona-server-client-5.7
also percona-release setup ps80 works as expected

vagrant@debian-10:~$ sudo percona-release setup ps80
* Disabling all Percona Repositories
* Enabling the Percona Server 8.0 repository
* Enabling the Percona Tools repository
Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 http://httpredir.debian.org/debian buster InRelease
Hit:3 http://httpredir.debian.org/debian buster-updates InRelease
Hit:4 http://repo.percona.com/prel/apt buster InRelease
Get:5 http://repo.percona.com/ps-80/apt buster InRelease [15.8 kB]
Get:6 http://repo.percona.com/tools/apt buster InRelease [15.9 kB]
Get:7 http://repo.percona.com/ps-80/apt buster/main Sources [2351 B]
Get:8 http://repo.percona.com/ps-80/apt buster/main amd64 Packages [32.7 kB]
Get:9 http://repo.percona.com/tools/apt buster/main Sources [10.2 kB]
Get:10 http://repo.percona.com/tools/apt buster/main amd64 Packages [41.0 kB]
Fetched 118 kB in 1s (103 kB/s)                            
Reading package lists... Done
1 Like

Hi, I have another Debian 10 VM, it’s weird. I am still having the same issue

I changed the /etc/apt/sources.list to use on the VM I have the issues, withthe sources.list from the VM I don’t have the issue, and I changed from http to https

deb Index of /debian buster main
deb-src Index of /debian buster main

deb Index of /debian-security buster/updates main contrib
deb-src Index of /debian-security buster/updates main contrib

buster-updates, previously known as ‘volatile’

deb Index of /debian buster-updates main contrib
deb-src Index of /debian buster-updates main contrib

But even with that, I am still getting issues:

I tried with:

percona-release_1.0-27.generic_all.deb, which is latest

Preparing to unpack percona-release_1.0-26.generic_all.deb …
Unpacking percona-release (1.0-26.generic) over (1.0-27.generic) …
Setting up percona-release (1.0-26.generic) …
Specified repository does not exist: Percona Repo
Specified repository does not exist: Percona Repo

The repository does not exist???
If I open those 2link using Firefox, I have not problem reaching those URLs.

One thing I notice, the warning/error is about http:// but if I try manually from the server, https:// it could be reach

[root@VM (QA5 /tmp] wget http://repo.percona.com/apt/percona-release_latest.buster_all.deb
–2022-02-08 10:20:12-- http://repo.percona.com/apt/percona-release_latest.buster_all.deb
Resolving repo.percona.com (repo.percona.com)…
Connecting to repo.percona.com (repo.percona.com)||:80… connected.
HTTP request sent, awaiting response… 403 Forbidden
2022-02-08 10:20:12 ERROR 403: Forbidden.

Now using HTTPs

[root@VM (QA5 /tmp] wget https://repo.percona.com/apt/percona-release_latest.buster_all.deb
–2022-02-08 10:20:07-- https://repo.percona.com/apt/percona-release_latest.buster_all.deb
Resolving repo.percona.com (repo.percona.com)…
Connecting to repo.percona.com (repo.percona.com)||:443… connected.
HTTP request sent, awaiting response… 200 OK
Length: 11804 (12K) [application/x-debian-package]
Saving to: ‘percona-release_latest.buster_all.deb’

percona-release_latest.buster_all.deb 100%[===================================================================================>] 11.53K --.-KB/s in 0s

2022-02-08 10:20:07 (205 MB/s) - ‘percona-release_latest.buster_all.deb’ saved [11804/11804]

Any ideas why using the same Debian 10, and the same sources (APT) file, I will get different results?


1 Like