Unable to Install or get results sent , Mysql 5.6 not being detected

My System Details :
CentOS release 6.5 (Final)
MySQL : Server version: 5.6.15-56 Percona Server (GPL), Release rel63.0, Revision 519
How I installed :

I followed the guide on the website. Added the percona tools repo in yum.
pt-agent --install

I keep getting errors in my agent details area on percona cloud tools. It’s not showing mysql version correctly.

I have tried installing and reinstalling several times. I have been completely unable to make any use of this. I have manually tried and checked the login details inside /etc/percona/agent/my.cnf . I’ve manially made sure this account has super , and all dba admin login access. I’ve manaully tried logging in. I tried stoping via --stop flag a few times, but still no go.

Any advise ?

error examples :

error that shows up on the list og agents :
MySQL connection failure: DBI connect(’;mysql_read_default_file=/etc/percona/agent/my.cnf;host=localhost;mysql_read_default_group=client’,‘pt_agent’,…) failed: Access denied for user ‘pt_agent’@‘localhost’ (using password: YES) at /usr/bin/pt-agent line 2365

Percona Server [INDENT=4][COLOR=#C09853]Install Percona Server 5.1.47 or greater to enable extended slow log metrics.[/INDENT]

Looks like the issue with mysql not being able to connect is me using the default configuration from another account.

Thank you for your post a was trying to find whats wrong about 8 hours!! Thanks