trying PMM Server at VMWare : fails to open the downloaded OVA file

Greetings

I’m trying the first trial install of PMM Server at VMWare platform.
Had downloaded the file pmm-server-1.13.0.ova.
However, unable to open/import that file into VMWare - got error messages :
The OVF package requires unsupported software,
Details: Line 80: OVF hardware element ‘Resource Type’ with instance ID ‘5’: No support for the virtual hardware device type ‘20’.

Any assistance with that issue resolution is very appreciated.

Regards,
Avi

Hi there, thanks for your question.
Can I just check that you are using VMware - ESXi 6.5 please as that’s the one that we support ( see https://www.percona.com/doc/percona-monitoring-and-management/deploy/server/virtual-appliance.html )

Hey
Thanks for the fast answer.
Our VMWare version is 6.5.0.

If i unpack the downloaded OVA file by tar, and try to use the OVF file from that tar - i get the following error :
“The provided manifest file is invalid: Invalid OVF checksum algorithm : SHA1 .”

Any assistance with that issue resolution is very appreciated…

Greetings,

I’ve managed to continue with the import. Currently i’ve got messages :
… dracutinitqueue [222]: Warning: dracut-initqueue timeout - starting timeout scripts
… dracutinitqueue [222]: Warning: Could not boot.

How can this be fixed ?

Regards and looking forward your assistance,
Avi

The messages are :
… dracut-initqueue [222]: Warning: dracut-initqueue timeout - starting timeout scripts
… dracut-initqueue [222]: Warning: Could not boot.

It seems that the PMM Server OVA files available for download - are suitable for Virtual Box, and not so suitable for VMWare.
Is it possible to find/download an OVA/OVF file made/designed for VMWare ?

Hello, sorry for the delay.

My understanding is that the VMWare OVA/OVF file we have supports VMware - ESXi 6.5 and if you don’t use that version there may be an issue.

You mention the version number (above) but not the implementation (sorry if that’s not the correct term). I discussed your issue with our team and they think it is likely that you are not using ESXi 6.5.

If you ARE using VMware ESXi 6.5 then please could you confirm that specific version since then I will be able to get this issue resolved. If it’s not this implementation, there may not be a positive response in the short term, though hopefully we might be able to support other releases in due course.

Here is the page that outlines what we can support today: https://www.percona.com/doc/percona-…appliance.html

Hello

Many thanks for the answer.

The VMWare version we’ve tried is :
VMkernel xxxxxxxx.yyyyy.com 6.5.0 #1 SMP Release build-5969303 Jul 6 2017 21:22:25 x86_64 x86_64 x86_64 ESXi

Regards

VMware ESXi 6.5 is supported by PMM OVA, but according to the error text we think you might be using VMware vCenter 6.5, which we don’t currently have an implementation for.
Could you please make a screenshot of the web interface to show where you import PMM OVA and get the ERROR. Then we might be able to establish if that hunch is correct or not.

Unfortunately, the differences might be subtle but enough to cause a problem. If you send the screenprint, we can check it out.

It appears that we don’t have here the VMware Workstation Player.
All the trials were done rather with VMWare vSphere Client (probably what you call VMWare vCenter).
i shall upload some screenshots.

So, do you mean the the currently available OVA files are suitable just and only for VMware Workstation Player ?

Any assistance with that issue resolution is very appreciated…

Hi avi vainshtein

Apologies for the delay in replying to you. Percona strives to support all platforms that claim acceptance of the OVF format, however the VMware platform provides a set of challenges since the Enterprise platform is not free ($$) and we don’t use VMware internally, so we don’t have an Enterprise environment on which we can test before we release. This is why we can assure you the product works on VMware Workstation Player. I am looking into building a relationship with VMware but this is proving more challenging than I expected, so in the short term I do not yet have any guidance for you, other than I have heard reports that users of VMware Enterprise are able to still use PMM Server when they import the image at the node level, and not through vSpere / vCenter.

I’ll update this thread when I have new details to report. Thanks for your patience avi vainshtein !

Hello Michael

Many thanks for the update.

What are other/alternative methods to install/configure PMM Server at a Linux machine ?
The methods listed at https://www.percona.com/doc/percona-monitoring-and-management/deploy/index.html are :

  • Running PMM Server via Docker
  • PMM Server as a Virtual Appliance
  • Running PMM Server Using AWS Marketplace

Virtual option didn’t work for us till now. We can’t/don’t use AWS, since our network is an offline net (no direct internet access).
Does it mean that the only left option is Docker ? (we have no experience with it)
Don’t you have an RPM-install option ?

Any assistance with that issue resolution is very appreciated…

i install pmm-server on local esx6.5 then i upload my vmdk to esx 5.5. It’s working. when you have a running appliance you could migrate it “where you want” like any other VM…

Thanks for clarifying Yathus

We just recently obtained license keys for VMware Data Center edition so in future releases we’ll be able to properly validate PMM Server against vCenter. Thanks for the workaround!

It is a software issue so the download is not working. You can check the official site of this software and download the latest version.

Hi CassieGriffin

Can you help me clarify your comment - are you providing perspective that the OVA doesn’t work correctly with your vCenter environment?

A workaround is to import using ESXi directly (avoid vCenter import).

Percona IT is working to deploy the VMware environment for us to test this internally, and we strive to make our 1.15 release (scheduled for Oct 10) compliant with VMware vCenter.

Hi Michael,

Some time ago, we to faced issues with exporting .ovf images and importing them in other environments with the same error.
The fix that i found, was to export the package with the VMware OVF tool with this line (for windows):

"C:\Program Files\VMware\VMware OVF Tool"ovftool.exe --noSSLVerify --shaAlgorithm=sha1 vi://esxi-ip/vm-name E:\cloud_exports\

If you can try this fix and upload the new .ovf for test purposes, it would be my pleasure to confirm the workaround as i have two clusters on VMware Vcenter 6.5.

Thank you,
Marius