Trouble with Mongodb & Cacti Monitor Plugins

Love your work!

After downloading the plugins for cacti I got right to monitoring my Mysql DB. And life is good.
So I tried the Redis tools, and after a quick adjustment in the ss_get_by_ssh.php graphing of Redis springs to life. Great!
So Mongo is next. Same ssl, keys, no changes to the cacti env. It looks good so far… but data never populates. :frowning:

manually run the php from the cacti host as described in the documents; php /usr/share/…/ss_get_by_ssh.php --type mongodb --host my-host --items mk,ml

Result returned is mk:-1 ml:0
I get this result if run as root or cacti. Since this was similar to my Redis deployment, I figured ssh was the issue. After manually ssh’ing into the mongo server, running the query, I get plenty of results. Yet I’m still get a -1 return from the cacti host. I try this on all the --items for mongo… and ~75% return -1 while the rest return 0

I’m new to Percona and only just relearning Cacti.
Anyone able to help me out?


Bump… any suggestions, anyone?

I don’t understand why this is not working.
from the mongo db host I see the valid ssh connections
Jul 23 17:47:20 sshd[3872]: Accepted publickey for root from port 55998 ssh2
Jul 23 17:47:21 sshd[3872]: Received disconnect from : 11: disconnected by user

On the cacti-host, in /tmp/_mongodb_cacti_stats.txt I can see the temp file for the stats. contain this;

gg:-1 gh:-1 gi:-1 gj:-1 gk:-1 gl:-1 gm:-1 gn:-1 go:-1 gp:-1 gq:-1 gr:-1 gs:-1 gt:-1 gu:-1 gv:-1 gw:-1 gx:-1 gy:-1 gz:-1 hg:-1 hh:-1 hi:-1 hj:-1 hk:-1 hl:-1 hm:-1 hn:-1 ho:-1 hp:-1 hq:-1 hr:-1 hs:-1 ht:-1 hu:-1 hv:-1 hw:-1 hx:-1 hy:-1 hz:-1 ig:-1 ih:-1 ii:-1 ij:-1 ik:-1 il:-1 im:-1 in:-1 io:-1 ip:-1 iq:-1 ir:-1 is:-1 it:-1 iu:-1 iv:-1 iw:-1 ix:-1 iy:-1 iz:-1 jg:-1 jh:-1 ji:-1 jj:-1 jk:-1 jl:-1 jm:-1 jn:-1 jo:-1 jp:-1 jq:-1 jr:-1 js:-1 jt:-1 ju:-1 jv:-1 jw:-1 jx:-1 jy:-1 jz:-1 kg:-1 kh:-1 ki:-1 kj:-1 kk:-1 kl:-1 km:-1 kn:-1 ko:-1 kp:-1 kq:-1 kr:-1 ks:-1 kt:-1 ku:-1 kv:-1 kw:-1 kx:-1 ky:-1 kz:-1 lg:-1 lh:-1 li:-1 lj:-1 lk:-1 ll:-1 lm:-1 ln:-1 lo:-1 lp:-1 lq:-1 lr:-1 ls:-1 lt:-1 lu:-1 lv:-1 lw:-1 lx:-1 ly:-1 lz:-1 mg:-1 mh:-1 mi:-1 mj:-1 mk:-1 ml:0 mm:0 mn:0 mo:-1 mp:-1 mq:-1 mr:-1 ms:-1 mt:-1 mu:-1 mv:-1 mw:-1 mx:-1 my:-1 mz:-1 ng:-1 nh:-1 ni:-1 nj:-1 nk:-1 nl:-1 nm:-1 nn:-1 no:-1 np:-1 nq:-1 nr:-1 ns:-1 nt:-1 nu:-1 nv:-1 nw:-1 nx:-1 ny:-1 nz:-1 og:-1 oh:-1 oi:-1 oj:-1 ok:-1 ol:-1 om:-1 on:-1 oo:-1 op:-1

If I ssh manually with the same user and ssh key I use in the ss_get_by_ssh.php, into the mongo-host and run the command below I get complete success. I’m thinking a path issues?
db._adminCommand({serverStatus : 1});

Problem solved.

I am having the same issue listed here. ss_get_by_ssh.php works great to my other monitors. It is collecting CPU, memory, networking, etc from my mongoDB server. It just wont pull the mongoDB status.

I do have authentication in place for my mongoDB and I am guessing thats the issue but have not been able to find any documentation on where to configure that.

I am running Percoan Monitoring Tools 1.1.3, i am not opposed to installing 1.1.5 the latest at this time but I was hoping for some direction to go in before that.

Same issue here with authentication being the likely culprit - anybody here resolve this?