Some package asks for libmysqlclient and mysql-common packages after installation of Percona Server. How do it solve?

There was Mysql 8.0.32 installed on Ubuntu 18.04.
As well Asterisk, Freeradius, Zabbix were instelled here.
Then I founded Percona Server (mysql) which I read that better then Mysql itself and decided to move to Percona Server.
When I was installing the software, it asked for remove mysql server with all dependency, including libmysqlclientX and mysql-common.
But with libmysqlclientX and mysql-common.was removed asterisk-mysql, freeradius-mysql, zabbix-mysql and some other packages.
Ok, I agreed and Percona-Server was installed successfully including libperconaserverclient21 and percona-server-common.
But when I tried to reinstall asterisk, freeradius, zabbix and some other applicatios, I prompted to install libmysqlclientX and mysql-common.
If I agreed with installation of it, Percona server had to be deleted amd Mysql server was installed again.

All package working with mysql I installed from packages, not from sources as following I can’ t change its dependencies.

How is to solve it ?

Hi @CpServiceSPb welcome to the Percona forums!

Did you use the percona-release binary to manage your repositories? This works for both deb and rpm based systems. Using percona-release ensures that dependencies are properly maintained between packages.

I have tried to install asterisk-mysql and other packages with Percona-Server-8.0.30 and everything was ok. Could you please provide exact commands that you executed