Odd apt conflict

I’m running percona-sql-server-5.0 (5.0.91) on Ubuntu Intrepid and have run into this strange apt conflict:

The following packages are BROKEN: libaprutil1-dev percona-sql-client-5.0 percona-sql-server-5.0 The following NEW packages will be installed: percona-server-common{a} The following packages will be REMOVED: libmysqlclient15-dev{a} percona-sql-common{a} 0 packages upgraded, 1 newly installed, 2 to remove and 0 not upgraded.Need to get 8868B of archives. After unpacking 26.9MB will be freed.The following packages have unmet dependencies: percona-sql-server-5.0: PreDepends: percona-sql-common but it is not installable percona-sql-client-5.0: Depends: percona-sql-common but it is not installable libaprutil1-dev: Depends: libmysqlclient15-dev but it is not installableThe following actions will resolve these dependencies:Keep the following packages at their current version:percona-server-common [Not Installed]percona-sql-common [5.0.91-percona-b22.intrepid.5 (, now)]Downgrade the following packages:libmysqlclient15-dev [5.0.67-0ubuntu6.1 (intrepid-updates, intrepid-security, now) -> 5.0.67-0ubuntu6 (intrepid)]Score is 161

This looks like a dependency conflict inside the Percona packages. I’ve fixed it for now by removing the dev library, but that suggests there is no dev lib for this version of the percona server. Should this be reported as a bug or is it intentional?

You really should try to keep all the mysql related packages consistent - install them from ubuntu repo OR from Percona one.

Right now you have conflict between ubuntu ones (5.0.67-0ubuntu6.1) and Percona (5.0.91-percona-b22.intrepid.5).

I resolved that by setting the Percona repo higher priority.
To achieve this you create a file, i.e.:
and put this inside:

Package: *
Pin: release l=percona
Pin-Priority: 700

Then do apt-get update before you update packages.
In worst case you may need to do dpkg --purge on some broken packages.
(Didn’t test it on intrepid, but worked for me on karmic)