Percona client installation failed in linux server with aarch64 architecture

I am trying to install Percona client on two different Linux servers with the same ubuntu version (20.04.2 LTS), but with different architecture. The percona client got successfully installed in the server with x86_64(amd64) architecture but failing to install in the server with aarch64 architecture. I am facing the following error in the server with aarch64-


Steps followed to install the percona client

  1. Download Percona Repo Package

wget$(lsb_release -sc)_all.deb

  1. Install Percona Repo Package

sudo dpkg -i percona-release_latest.$(lsb_release -sc)_all.deb

  1. Update apt-cache

sudo apt-get update

  1. Install Percona Monitoring and Management Client

sudo apt-get install pmm2-client

I followed the installation steps given in the below link.

Please suggest a solution to install percona client in Ubuntu with aarch64 architecture.

Hello. Percona does not provide precompiled packages for ARM processors. You will need to download the source code and compile for your processor. You can use the following instruction for this: Compiling a Percona Monitoring and Management v2 Client in ARM Architecture - Percona Database Performance Blog .


Thanks for your kind reply. Now I am facing an issue when following the steps given in the link shared earlier for compiling pmm client for the ARM architecture.

vendor/ No such file or directory

Command used:

wget -O vendor/ \

I tried replacing ‘lfittl’ with ‘pganalyze’ in the command as said in the link below. But still, I am getting the same error.

Please suggest a solution to this issue.

Hi @suryajai,

For Ubuntu, you will actually want to read my reprise blogpost:

That has the updated steps you’ll need. Let us know how it goes!

1 Like