Notification Channel email failing

Configured a notification channel using email and am getting authentication errors.

grafana.log:

t=2021-09-29T19:44:28+0000 lvl=info msg=“Sending alert notification to” logger=alerting.notifier.email addresses=[mike.morley@idealagent.com] singleEmail=true
t=2021-09-29T19:44:29+0000 lvl=eror msg=“Failed to send alert notification email” logger=alerting.notifier.email error=“Failed to send notification to email addresses: mike.morley@idealagent.com: 535 5.7.8 Error: authentication failed: authentication failure”
t=2021-09-29T19:44:29+0000 lvl=eror msg=“failed to send notification” logger=alerting.notifier uid= error=“Failed to send notification to email addresses: mike.morley@idealagent.com: 535 5.7.8 Error: authentication failed: authentication failure”
t=2021-09-29T19:44:29+0000 lvl=eror msg=“failed to send notification” logger=alerting.notifier uid= error=“Failed to send notification to email addresses: mike.morley@idealagent.com: 535 5.7.8 Error: authentication failed: authentication failure”
t=2021-09-29T19:44:29+0000 lvl=eror msg=“Failed to send alert notifications” logger=context userId=1 orgId=1 uname=admin error=“Failed to send notification to email addresses: mike.morley@idealagent.com: 535 5.7.8 Error: authentication failed: authentication failure” remote_addr=47.207.31.145
t=2021-09-29T19:44:29+0000 lvl=eror msg=“Request Completed” logger=context userId=1 orgId=1 uname=admin method=POST path=/api/alert-notifications/test status=500 remote_addr=47.207.31.145 time_ms=451 size=73 referer=https://192.155.93.57/graph/alerting/notification/1/edit

grafana.ini smtp details…

[smtp]
enabled = true
;host = smtp.zoho.com:587
host = smtp.frontier.com:465
user = mike.morley813@verizon.net
;user = mike.morley@idealagent.com

If the password contains # or ; you have to wrap it with triple quotes. Ex “”"#password;"""

password = XXXXX
;cert_file =
;key_file =
skip_verify = false
from_address = mike.morley813@verizon.net
!from_name = Grafana

EHLO identity in SMTP dialog (defaults to instance_name)

;ehlo_identity = dashboard.example.com

SMTP startTLS policy (defaults to ‘OpportunisticStartTLS’)

;startTLS_policy = NoStartTLS

Well the error is an SMTP error so you’re communicating outside the environment to the Frontier SMTP server so that’s good!

I assume that frontier/verizon are now one entity and the verizon.net username/pass combination works against frontiers infra…if you don’t have another client (outlook, thunderbird) relaying via SMTP through frontier might be worth checking.

I’m most suspicious of this being a TLS/SSL issue which a quick google shows ssl is required for Frontier and I’ll be honest, I’ve never tried to set tls to required…so I’ll play with that now against gmail but you might try the startTLS_policy=MandatoryStartTLS setting just to see if it’ll force TLS.

1 Like