innobackupex --incremental is very slow

We running a incremental right after the full backup is completing (3h)

innobackupex --no-backup-locks --throttle=40 --parallel=4 --use-memory=5G --rsync --no-timestamp --user=root --password=VOqvfKCc7mB_jM --databases=“${db_list}” $BACKUP_FOLDER

to_lsn=grep to_lsn ${BACKUP_FOLDER}/xtrabackup_checkpoints | awk '{ print $3 }'
innobackupex --no-lock --safe-slave-backup --no-backup-locks --throttle=30 --parallel=4 --use-memory=5G --rsync --no-timestamp --user=root --password=VOqvfKCc7mB_jM --databases=“${db_list}” --incremental /bkp/inc --incremental-lsn=$to_lsn

And now this incremental is taking longer than full backup - running already 4h

Any one can help?

Hi there, is this a new set up? Or is it a long lived process that’s suddenly started acting differently?

Could you let us have the version of innbackupex, what you’re backing up (e.g. MySQL, Percona Server for MySQL), versions and environment info? Meanwhile I’ll see if there’s anyone about with suggestions…

MySQL is Percona:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 1244039
Server version: 5.7.19-17-log Percona Server (GPL), Release 17, Revision e19a6b7b73f

innobackupex version 2.4.13 based on MySQL server 5.7.19 Linux (x86_64) (revision id: 3e7ca7c)

CentOS Linux release 7.3.1611 (Core)


Location: Google Cloud

I tried with 40 also - same result.

It is a new setup - the backup solution.
The server is already running for about 1-1.5 year

Thank you

Hello again, apologies for the delay in response, I’ve been out of office.
Would you be able to provide the logs of full and incremental backup? We need to be able to pinpoint where the back up is taking its time. I can let you have an email address if you don’t want them to be made publicly available.