FATAL this authentication plugin is not supported

While setting up orchestrator, on trying to start it up , it throw the exception : FATAL this authentication plugin is not supported. Am on latest mysql version 8.0.25-15 Percona Server (GPL), Release 15

In debug mode below are the message appear:
orchestrator]# cd /usr/local/orchestrator && ./orchestrator --debug --stack http
2021-10-01 01:14:38 INFO starting orchestrator
2021-10-01 01:14:38 INFO Read config: /etc/orchestrator.conf.json
2021-10-01 01:14:38 DEBUG Initializing orchestrator
2021-10-01 01:14:38 DEBUG Migrating database schema
2021-10-01 01:14:38 FATAL this authentication plugin is not supported
goroutine 1 [running]:
runtime/debug.Stack(0x0, 0x0, 0x0)
/usr/local/bin/go/src/runtime/debug/stack.go:24 +0x80

[root@mysql-dr-monitor-svr-01 orchestrator]# mysql -uroot -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 18
Server version: 8.0.25-15 Percona Server (GPL), Release 15, Revision a558ec2

Copyright (c) 2009-2021 Percona LLC and/or its affiliates
Copyright (c) 2000, 2021, Oracle and/or its affiliates.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective

Anyone ever encoountered such an issue? Mysql error logs does not show anything. Selinux is in permissive mode.

1 Like

MAnaged to resolve this on my own, I tried it on a lower version of mysql and it worked.

1 Like