Current version : "Check for updates manually" not showing (in loading state)

Hi ,

PMM “Home Dashboard” - Current Version / Check for updates manually" not showing any thing and in loading state.
i tried reloading page, using incognito mode etc…
I have also tries to stop and start the docker but no luck…

Please refer to the below snap shot.

Can any one help?

Thank you in advance.

I was facing the same issue with an OVA installation.

I solved it by ssh-ing into the instance and running

sudo pmm-update-check

followed by

sudo pmm-update

After the update the “Current version” panel is working again.

However for the docker version I would choose the upgrade path described here:
https://www.percona.com/doc/percona-monitoring-and-management/section.deploying.pmm-server.docker.upgrading.html#update-server-docker

HTH,
Robert

Thanks Robert for sharing details. I will try and let you know…

Thank you Robert…It worked.

I hope once the next version is realised i will be able to see in “Updates” section.

Thank you for your help.

Vaibhav

Wanted to pop up and say thanks to Robert for the suggestion that worked and thanks to Vaibhav for confirming. Appreciated, both!