Cannot run donor command on CLI

I am using CentOS 7 and pxc version 5.6.

As per this blog https://www.percona.com/blog/2014/09/01/galera-replication-how-to-recover-a-pxc-cluster/

im trying to run the below command and and i am getting error.

systemctl start mysql --wsrep-sst-donor=srv1

systemctl: unrecognized option ‘–wsrep-sst-donor=srv1’

Hi there I think we might have answered on dba.stackexchange? For Centos 7 that blog says to use

systemctl start mysql@bootstrap.service 

I will double check with the tech team here to make sure that is correct advice…

https://dba.stackexchange.com/questions/223998/percona-xtradb-cluster-not-accepting-options-on-command-line

Hello loraine, can you pls check my updated question in dba stackexchange?
I want to manually select the donor and i cannot run the command.

however, i believe that bootstrap is needed for the first node.

Hi Jazikh,

Unfortunately the systemctl doesn’t take extra options the same way as pre-systemd init.d script did.
Although you can edit the /usr/lib/systemd/system/mysql.service and add the option to the ExecStart line, I would suggest to rather add it temporarily to your .cnf configuration file (for PXC 5.7 it will be /etc/percona-xtradb-cluster.conf.d/wsrep.cnf), just without the ‘–’ prefix.
Hope that works.

Thanks:rolleyes: