Percona Xtradb Cluster not accepting options on command line

I am using Percona Xtradb Cluster 5.7 and trying to start my cluster through a donor node via command line and I am getting this error:

[root@pxc1 mydata]# systemctl start mysql --wsrep_sst_donor=pxc3
systemctl: unrecognized option ‘–wsrep_sst_donor=pxc3’

I am running 3 nodes cluster. I have started my first node-A with bootstrap, then started second node-B which synced with node-A and now i want my third node-C to sync with the first one node-A as well, but it seems not possible. Is to possible at all to do this on centos7?

Nobody has nothing to say about his issue?

Hi there, thanks for your question.

For someone to help you, and therefore to get quicker attention on the Forum, you have to provide much more information for example my.cnf from every node, any log files that are getting written, is this a new installation or an existing one that is causing trouble, what is the specific version of Percona XtraDB Cluster that you are using, is there anything “special” about your server environment etc etc

Without this information it’s hard for engineers to help. Here’s a post that tells you a little more: https://www.percona.com/forums/quest…o-report-a-bug

If you need help in a specific time scale, then we do offer paid support services. With paid support you get a guaranteed response time. With the open source community forum, then there’s no guarantee of a response, but the more information you provide, the more likely it is that someone will be able to quickly see an issue and help you out.

Hope this helps.

Hello, thanks for your response.

Find below the requested info:

–Percona Server version:

5.7.25-28-57-log

–SO version

CentOS Linux release 7.6.1810 (Core)

–Percona my.cnf file (this is the same on the 3 nodes)

[mysql]

CLIENT

port = 3306
socket = /mydata/mysql.sock

[mysqld]

GENERAL

user = mysql
default-storage-engine = InnoDB
socket = /mydata/mysql.sock
pid-file = /mydata/mysql.pid
#old_passwords = 1

MyISAM

key-buffer-size = 32M
myisam-recover-options = FORCE,BACKUP

#Enable Federated Storage Engine
federated

SAFETY

max-allowed-packet = 128M
max-connect-errors = 1000000

DATA STORAGE

datadir = /mydata

BINARY LOGGING

log-bin = /mydata/mysql-bin
expire-logs-days = 1
sync-binlog = 1
server_id = 1

CACHES AND LIMITS

tmp-table-size = 32M
max-heap-table-size = 32M
query-cache-type = 0
query-cache-size = 0
max-connections = 500
thread-cache-size = 50
open-files-limit = 65535
table-definition-cache = 4096
table-open-cache = 4096

INNODB

innodb-flush-method = O_DIRECT
innodb-log-files-in-group = 2
innodb-log-file-size = 512M
innodb-flush-log-at-trx-commit = 1
innodb-file-per-table = 1
innodb-buffer-pool-size = 1456M

LOGGING

log-error = /var/log/mysqld.log
log-queries-not-using-indexes = 1
#slow-query-log = 1
#slow-query-log-file = /var/lib/mysql/mysql-slow.log

## XTRADB PARAMETERS ##

wsrep_provider=/usr/lib64/galera3/libgalera_smm.so

wsrep_cluster_name=pxc-cluster-dev
wsrep_cluster_address=gcomm://10.10.10.2,10.10.10.3,10.10.10.4

wsrep_node_name=pxc1
wsrep_node_address=10.10.10.2

wsrep_sst_method=xtrabackup-v2
wsrep_sst_auth=“xxxxxxxxxxx”
wsrep_replicate_myisam = 1
wsrep_slave_threads=2

#gcache.size
wsrep_provider_options=“gcache.size=768M;gcache.recover = yes”

binlog_format=ROW
innodb_autoinc_lock_mode=2

[mysqldump]
max-allowed-packet = 128M

Somebody has a clue how to start a node of a cluster through a donor with --wsrep_sst_donor option?

I am sorry, ekonomi, but you cannot expect instant responses from a non-paid forum.

If you need fast responses from the Percona team then I am afraid that you will have to pay for support. The Forum should not be mistaken for “free support”.

FWIW I have asked the team to look at your question when they have some time but the forum is not their priority. It may be that a community member will help you quicker, or if you need instant help please consider our support options. https://www.percona.com/services/support/percona-support-levels

You should also try searching our site for help, for example this may well apply to you (bottom answer): https://www.percona.com/forums/questions-discussions/percona-xtradb-cluster/53007-cannot-run-donor-command-on-cli

It’s funny that you gave a mysqld option “–wsrep_sst_donor” to the linux command “systemctl”.
you can try startup mysqld manually and try again.

https://mariadb.com/kb/en/library/starting-and-stopping-mariadb-getting-systemctl-start-mysql-wsrep_new_clust/

Hi ekonomi,

Instead of passing wsrep_sst_donor on the command line, you should set the same in the my.cnf of joiner node.

[pxc1] vim /etc/my.cnf or the config file in use.

[mysqld]

wsrep_sst_donor=pxc3

Save my.cnf and start MySQL service, It should use pxc3 as a donor for SST. You can confirm the same from error logs of pxc1 while SST is running.

[pxc1] systemctl start mysql

Once pxc1 has joined the cluster, you can comment the line “wsrep_sst_donor…” if you want.

Thank you lorraine.pocklington, I appreciate your kindness and help!

:slight_smile: you’re welcome.

Feel free to ask any time… but also try to be a little bit patient :wink: