Cannot register to OVF pmm server. 401 Authorization Required

I followed a percona document on installing the ovf version of the pmm server. All seemed to go well until I got to the point of registering a client.

$ pmm-admin config --server-insecure-tls --server-url=https://admin:admin@pmm.srv:443
Checking local pmm-agent status…
pmm-agent is running.
Registering pmm-agent on PMM Server…
Failed to register pmm-agent on PMM Server: response from nginx:

401 Authorization Required

401 Authorization Required

nginx . I've read countless articles since then trying to find the problem and have tried just as many ways to register but in the end, the above seems to be the problem.

I cannot ssh into the server (can’t find any info on enabling ssh) so cannot use any method given on how to perhaps update the self signed cert which seems to be the problem.
I don’t see any options in the GUI for doing so.

Doc also says how to log in from a client which doesn’t work, there is no such option.

$ pmm-admin config --username=xxx --password=xxx --server=
pmm-admin: error: unknown long flag ‘–username’, try --help

Two days later, I’m frustrated enough to have to post asking for help… help!

Server is running on ESX 6.7 and is 1.17.14.

$ pmm-admin --version
ProjectName: pmm-admin
Version: 2.27.0
PMMVersion: 2.27.0
Timestamp: 2022-04-13 16:31:42 (UTC)
FullCommit: 7ed31986c611051228913366fbf6f61dec9e08a0

1 Like

Hi @perplexed

It looks like you installed PMM server of version 1.x and PMM client of version 2.x
Here is the link for installing PMM 2.x server.

1 Like

Hi, yes, I figured that out after posting but could not edit since I included a link which got my post held for moderation. All is good now.

Thanks for your help.

1 Like