Failed to register pmm agent on PMM Server (Unexpected EOF)

Hi, i have a problem when register pmm agent
it said : Failed to register pmm-agent on PMM Server: Post “https://IP_ADDRESS:443/v1/management/Node/Register”: unexpected EOF.

what does it mean and how to solve that?

Hi jpryg,

it is a little bit hard to say what is going on. I would guess firewall?

Could you please provide some details, how you start the agend, with what parameters and etc.


1 Like

firewall is disabled in both side
and i already open port 443, try to telnet <ip_server> 443 and its connected

i used this command to register the agent :
sudo pmm-admin config --server-insecure-tls --server-url=https://admin:<my_password>@<my_ip>:443

1 Like

it usually means that there is no connection or it is broken due to certificates issues.

Could please provide more details of your setup. What is running where? Do you have pmm-agent running?
Are pmm client and server are in different containers, hosts and etc?

Could you try curl -vvvv http://<ip_server>/v1/readyz and pmm-admin status ?

does that <my_ip> differs from <ip_server> ?

1 Like

could not understand (i’m new to pmm) but here’s the details :

i have 1 vm for pmm server and 3 vm for pmm client (this vm running mysql)
pmm server ip : 172.18.x.x
pmm client ip : 172.18.x.x

here’s what i’ve done :
installing docker for centos, pull the image percona/pmm-server:2
run the docker, try to run hello-world and it’s worked

then i followed the step from this tutorial : A Guide to Installing Percona Monitoring and Management (PMM)2 For the First Time - Percona Database Performance Blog

  1. run the command and succed (i can login to dashboard and change the password)
  2. install pmm2-client and succed
  3. configure pmm/register node : failed

q : does that <my_ip> differs from <ip_server> ?
a : same, not different.

1 Like

that might be outdated info.

could you please run from the client vm the command that I provided?
curl -vvvv http://<ip_server>/v1/readyz and pmm-admin status

It could fail because there is no connection, wrong certs (but you aren’t using ones), wrong user/pass.

Please provide the info and double check that you could connect from the client VM to the server docer container that is running on another one.

1 Like

i can’t access my server now, i’ll give an update on monday

1 Like


Here’s the update
when i run pmm-admin status : pmm-agent is running but not setup

and this is when i run command curl

1 Like


i want to give you an update, after unset the proxy (both side pmm-server and pmm-client), the pmm client can register succesfully