Bug in ss_get_mysql_stat / thread graph?

To me it looks like a bug in the

I monitor mutiple mysql servers with the Percona MySQL Cacti template. All plots are fine except for the Thread graph, ewhich is identicval for all servers.
Looking att he log file is seems like the --host option is set wrongly for the fetching of thread info.

/usr/bin/php -q /…/www/cacti/scripts/ss_get_mysql_stats.php --host cacti-log-db.mydomian.com --items it,iu,iv,iw,iy --user myuser --pass mypass --port --server-id , output: it:3 iu:21 iv:218 iw:1 iy:10

To mee it looks like it use the cacti backend DB server rather than the DB server ity should fetch statistics from.

Har anybody expeerience simliar problems?
Where can I report this as a bug?
Any suggestion for further debugging?

Regards Gjermundf

–host should specify a db server. Is cacti-log-db.mydomian.com your monitored db server or cacti backend one?
The host comes from device hostname in Cacti.

Sorry for not expressning my clearly.

I (We) have a couple of MySQL production servers, lets call them mysql_prod01 … mysql_prod20.
We have dedicatred webserver running cacti (and other monitoring tools), lets call it monitor.mydomain.com, further we ha a dedicated MySQL server as backend
storage for cacti, called cacti-log-db.

As you see form the log in my erlier post, it seems like the --host option is not set correctly. For all other graphs is is set like --host mysql_prodxx.
This happend for all server i monitor (prod01…prod20) so it look like all have identical thread graphs, which accutally is the threads from my cacti backend server.

I have been poking around in the code to try to find out where this is set without any sucess.

Regards Gjermund

Go to Data Input Methods > Percona Get MySQL Stats/MySQL Threads IM and check out if you have the input string like for other methods, i.e.

[HTML]<path_php_binary> -q <path_cacti>/scripts/ss_get_mysql_stats.php --host --items it,iu,iv,iw,iy --user --pass --port --server-id [/HTML]