Backing up a schema with a '$' in the name

After moving from MySQL 5.6 to 5.7, we had to move on from using mysqlhotcopy for backups due to 1) it being removed from the distribution and 2) some innodb tables now being present by default. After looking around, I settled on xtrabackup as it seemed like it would handle the innodb stuff and copy our myisam databases just like mysqlhotcopy used to. However, after running it for the first time last night, I notice that it didn’t back up any of our databases that contain a dollar sign in their name.

I used the --databases-file parameter and my file looks something like this:


It successfully backed up the first two databases but did nothing on the last two. We had a similar issue with mysqlhotcopy, but there was a patch available for it that made it possible to backup any such schemas. Is there anything that I can do to get xtrabackup to work with these databases?


As i doubt from your post, you tried to use partial backup command, try below command which will take a full back up of your MySQL data directory

Source Server
innobackupex --defaults-file=/etc/my.cnf --lock-wait-timeout=300 --user=user --password=password --tmpdir=/tmp --compress --stream=xbstream ./ | nc -l 1111

Destination Server
nc [destination IP ] 1111 | xbstream -C /local/inno_back -x

And after that you can run decompress and apply log, i hope it will solve your problem.