XtraBackup and MySQL 5.6

Hi,

I’m sure this Q has been asked somewhere before (or its obvious to everyone but me) but I’m unable to find anything searching the forum or web or Percona FAQ’s.

Is XtraBackup compatible with MySQL 5.6?

If its not then I understand why things arent working and I’ll just have to be patient and one day it may be available for that too. I know the online docs only mention up to 5.5 but nowhere does it tell me that it wont work with a newer version which is why I tried. If this is the case then please ignore the below.

I installed XtraBackup (latest) today for the first time on SuSE Linux (SLES11SP2). The RHEL repos wouldnt add when I tried so I went with the RHEL 2.05-499 x64 rpm install suggested here

www.percona.com/doc/percona-xtrabackup/installation/bin_dist ro_specific.html

I then ran what I thought was the simplest backup possible using the ffg command:

innobackupex-1.5.1 --user=root --password=‘xxxx’ /tmp

I get these results

InnoDB Backup Utility v1.5.1-xtrabackup
130311 15:59:55 innobackupex-1.5.1: Starting mysql with options: --password=xxxxxxxx --user=‘root’ --unbuffered –
130311 15:59:55 innobackupex-1.5.1: Connected to database with mysql child process (pid=28184)
130311 16:00:01 innobackupex-1.5.1: Connection to database server closed
IMPORTANT: Please check that the backup run completes successfully.
At the end of a successful backup run innobackupex-1.5.1
prints “completed OK!”.

innobackupex-1.5.1: Using mysql Ver 14.14 Distrib 5.6.10, for Linux (x86_64) using EditLine wrapper
innobackupex-1.5.1: Using mysql server version Copyright © 2000, 2013, Oracle and/or its affiliates. All rights reserved.
sh: --: invalid option

innobackupex-1.5.1: fatal error: no ‘mysqld’ group in MySQL options

Can anyone explain what I’m missing. Thanks

http://www.mysqlperformanceblog.com/2013/02/25/percona-welco mes-mysql-5-6/
Quote:

I think your warning is not related to 5.6, try googling the fatal error message.

Check you my.cnf do you have a section for mysqld?

[mysqld]
port =
datadir =

etc. etc.