Xtrabackup on Solaris10 (sparc)


I’ve tried downloading the 1.6.6 binaries for Solaris from the pre1_6 folder and have not gotten them to work with 64-bit Solaris10 (sparc). All I get is invalid argument.

bash-3.00$ ./xtrabackup --help
bash: ./xtrabackup: Invalid argument

We have a number of MySQL databases on Solaris sparc hardware and I’d like to be able to evaluate this software.

Also, it appears from my experimenting with the product for Linux, which does work, that I don’t seem to need to enter a username and password for xtrabackup, however innobbackupex seems to handle that, (we have multiple MySQL instances).

Does innobackupex deal properly with a mix of InnoDB and MyISAM tables in the same database?

Thanks for the real, and hopefully someone can steer me to the proper course of action

Hi Roger,
I tried downloading amd64 bit 1.6.6 binaries for Solaris and I had no issue running xtrabackup:
root@solaris:~/xtrabackup-amd64# ./xtrabackup --help
Open source backup tool for InnoDB and XtraDB

Copyright © 2009 Percona Inc.

This program is free software; you can redistribute it and/or
modify it under the terms of the GNU General Public License
as published by the Free Software Foundation version 2
of the License.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
GNU General Public License for more details.

You can download full text of the license on http://www.gnu.org/licenses/gpl-2.0.txt

Usage: [./xtrabackup [–defaults-file=#] --backup | ./xtrabackup [–defaults-file=#] --prepare] [OPTIONS]

Default options are read from the following files in the given order:
/etc/my.cnf /etc/mysql/my.cnf /usr/local/etc/my.cnf ~/.my.cnf
The following groups are read: mysqld xtrabackup
The following options may be given as the first argument:
–print-defaults Print the program argument list and exit.

Yes. The xtrabackup binary does not need a username/password combination but innobackupex does.
Backing up a mix of InnoDB and MyISAM in the same database with innobackupex is just fine. Do note that innobackupex can backup a mix of InnoDB and MyISAM tables while Xtrabackup will only backup InnoDB related data.

As for using Xtrabackup 1.6.6, since it’s old, you may want to use the latest version (2.0.2). However, you have to compile Xtrabackup 2.0.2 from source, test it in your environment and check if it fits your needs.

I haven’t tried this in Solaris 10, but in case you experience a compiler error due to to parameter mismatch with getpwuid_r and getgrgid_r functions, you can check https://bugs.launchpad.net/percona-xtrabackup/+bug/1033158 for a solution.

Hope this helps.

One of the things that jumps out at me right away with the example you provided is that I believe the xtrabackup command line string must end with the destination directory and nothing else.

shell # xtrabackup /path/to/directory

I hope this helps . . .

/David C.