Xtrabackup Error Cant't locate English.pm

VirtualBox 7.0

OS : Rocky Linux 9
DB : MySQL 8.0.33 (Master/Slave)

  • Master :,59201
  • Slave :,59202

Xtrabackup Version : 8.0.35

install process
Step1. yum install https://repo.percona.com/yum/percona-release-latest.noarch.rpm
Step2. percona-release enable-only tools
Step3. sudo yum install percona-xtrabackup-80
Step4. yum install qpress
Step5. yum install -y libev perl-DBD-MySQL perl-Time-HiRes

Exec Command

xtrabackup --default-file=/etc/my.cnf --user=root --password=1234 --backup --host= --port=59201 --socket=/tmp/mysql_59201.sock --target-dir=/sql_backup/mysql

Error Message 1

Can’t locate English.pm in @INC (you may need to install the English module) (@INC contains: /usr/local/lib64/perl5/5.32 /usr/local/share/perl5/5.32 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5) at - line 3.

Error Message 2

unknown variable ‘default-character-set=latin1’

Exec Command2

xtrabackup --prepare --target-dir=/sql_backup/

Error output Message

  1. cannot open ./xtrabackup_checkpoints
  2. failed to read metadata from ‘./xtrabackup_checkpoints’

I can’t find the cause of the error. help Me.
Reference website : https://iamwhat.tistory.com/44

This is no longer needed. Xtrabackup now uses ZSTD for compression.

You probably need to use CPAN to install this module, or use yum search to find an OS package for perl/English

Check your /etc/my.cnf and remove this parameter from any [client] sections.

thank you Thanks to you, I solved it.