xtrabackup doesn't prepare incremental backups

Hi everyone, I’m trying to prepare some incremental backups, but the program returns to me this line of log:

“xtrabackup: This target seems to be already prepared.
xtrabackup: error: applying incremental backup needs target prepared with --apply-log-only.”

But I already followed the manual and I stuck.

I’m make the full backup and this work perfectly, I run the incremental and all goes fine.
I prepare the full backup like manual said, and when I’m going to prepare the incremental backup it doesn’t work. the log above is showed and stops the program.

If anyone already see this, please help me!

thanks for any help

Hello Juliano

Can I just check that you have gone through the process described here: https://www.percona.com/doc/percona-xtrabackup/LATEST/xtrabackup_bin/incremental_backups.html#preparing-the-incremental-backups

Please also confirm the version of MySQL/MariaDB/Percona Server for MySQL and the verson of Percona XtraDB Backup. Thanks!

Hello Lorraine

Thanks for reply my thread, I looked the URL you send and I revise my scripts, for my sadness and happyness I found my bug. I have mistaken one single letter on my script, and a result for that is no function of the prepare incremental backups.

What I’m doing!
xtrabackup --prepare –aply-log-only –target-dir=$BACKUPDIR

What I’m have to do.
xtrabackup --prepare –apply-log-only --target-dir=$BACKUPDIR

A single letter is causing this issue.
Thanks for help

Hey no problem… Those typos get the best of us, it’s only when you step away for a while and go back that you get to see things.

Glad that you have fixed it though :smiley:

Don’t hesitate to come back if you have further questions, always welcome.