Updating Percona MySql on Ubuntu 12.10 Fails

I’m having some problems with an update here recently. First, I’m finding that a restart mysql is failing each time I attempt it with the following output in /var/log/syslog:

However, more importantly perhaps is when I tried to install the update (1:5.5.30-rel30.2-503.quantal) I received a failure. Each time I attempt to update anything else dpkg replies with the error and of course I can manually evoke the configuration and failure as follows:

dpkg --configure percona-server-server-5.5 # With the following output:

Finally, the following is in /var/log/syslog:

FYI, you have some serious editor problems in Safari and Chrome for creating posts here. URL insertion is not working properly in these forums and there are several other formatting problems here that preclude the ability to make nice looking posts in these two browsers I’ve tried. I spent about 20 minutes trying to make this post and with various iterations after seeing that it would fail miserably each time.

Note that for Debian and Ubuntu in order to have service control working properly, you need to have correct configuration in /etc/mysql/debian.cnf which has to point to the same socket file your running server is using. You can check which one is used with ps -ef|grep mysqld
Also the password must match the working one.
Another word speaking, following command must work in the first place, in order to any service control functions will work.

mysqladmin --defaults-file=/etc/mysql/debian.cnf ping

Also for upgrading the package, properly working service control is needed, as MySQL restart is a required step in installation process for Debian/Ubuntu.

ps thank you for report on Chrome/Safari issues, we’ll take a closer look.

Thanks for letting me know about debian.cnf. I did not see that in the installation instructions initially and so I was actually hesitant to modify this file as I thought that there must be a conflicting issue between Ubuntu and Percona.

This seems to have helped sort things out properly.

@TomD: one other item to perhaps note is that double line spacing happens a lot with code insertion. I tried to insert config items directly into my post initially, but the formatting problems made it look horrendous. I thought that the config items in your forum would help others find this topic more / help SEO, but obviously it’s a bugger to make it look right.