Standalone 5.7 install fails -- Ubuntu 14.04 LTS Bootstrap error 1105

I’ve upgraded 5 out of the 6 Percona 5.6 servers to 5.7 without /much/ trouble. In some cases the install of 5.7 failed, but a purge and re-install has always fixed it. Except for this one server we have. I’ve tried everything under the sun to get the v5.6 to v5.7 upgrade done to no avail. Since this isn’t a critical server I decided to purge 5.6 and install 5.7 directly. Even that is failing spectacularly. Here’s the relevant log portion:

2016-09-21T13:53:15.789795Z 0 [Warning] Changed limits: max_open_files: 1024 (requested 5000)
2016-09-21T13:53:15.789853Z 0 [Warning] Changed limits: table_open_cache: 431 (requested 2000)
2016-09-21T13:53:15.789977Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2016-09-21T13:53:17.570824Z 0 [Warning] InnoDB: New log files created, LSN=45790
2016-09-21T13:53:18.043510Z 0 [Warning] InnoDB: Creating foreign key constraint system tables.
2016-09-21T13:53:18.132105Z 0 [Warning] No existing UUID has been found, so we assume that this is the first time that this server has been started. Generating a new UUID: c0068305-8002-11e6-a3f2-0050569b72
2016-09-21T13:53:18.141806Z 0 [Warning] Gtid table is not ready to be used. Table ‘mysql.gtid_executed’ cannot be opened.
2016-09-21T13:53:18.765036Z 0 [Warning] CA certificate ca.pem is self signed.
2016-09-21T13:53:18.938585Z 1 [Warning] root@localhost is created with an empty password ! Please consider switching off the --initialize-insecure option.
2016-09-21T13:53:20.244025Z 1 [ERROR] Failed to open the bootstrap file /var/lib/mysql-files/SQL
2016-09-21T13:53:20.244050Z 1 [ERROR] 1105 Bootstrap file error, return code (0). Nearest query: 'LSE SET @sys.tmp.table_exists.SQL = CONCAT(‘SELECT COUNT(*) FROM ', in_db, '.', in_table, '’); PREPARE
stmt_select FROM @sys.tmp.table_exists.SQL; IF (NOT v_error) THEN DEALLOCATE PREPARE stmt_select; SET out_exists = ‘TEMPORARY’; END IF; END IF; END;

2016-09-21T13:53:20.244452Z 0 [ERROR] Aborting

The last three lines are the most important parts I think. But the Warning just above the first error is confusing. I entered in a password at the prompt (and I was root, not SUDO’d) and it’s still showing an empty password. I’ve Googled the errors, but the one fix I did find for this (using mysqld_safe) didn’t work for me. This server is identical to the other servers I’ve updated (they were made from the same VM template) and yet nothing appears to be working on this one.

Any ideas?