Trying to install innobackex

Hi, I tried installing Percona Toolkit using:


dpkg -i percona-toolkit.deb apt-get install --fix-missing -f 

Eventually I got that to work, but looking in

/usr/bin

there is no sign of

innobackupex

.
I can see all the

pt-*

files in there though.

I tried reinstalling using:

apt-key adv --keyserver keys.gnupg.net --recv-keys 1C4CBDCDCD2EFD2A

that gives me


. . .
gpgkeys: key 1C4CBDCDCD2EFD2A not found on keyserver
gpg: no valid OpenPGP data found.
gpg: Total number processed: 0

Then I try

apt-get install xtrabackup

which gives me


Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Unable to locate package xtrabackup

Am I doing something wrong?

I’ve also tried innobackupex, innobackupex_55, percona-toolkit, and they all have the same result.

Hi IGGt;

Xtrabackup is not part of the Percona Toolkit, so you will need to install it separately. Looks like you almost had it in the last step there. Try following the below guide to setup your apt repo, then you should be able to install it:

http://www.percona.com/doc/percona-xtrabackup/2.2/installation/apt_repo.html

-Scott

Related, but really an answer to your problem, I’ve had issues with a few of the load balanced instances of keys.gnupg.net not working for a few weeks. Maybe 10-15% of new installs (with Chef) fail due to the keyserver being broken.

cheers for your responses.
It turns out that there was a problem with the Proxy Server blocking access. Once this was fixed, everything worked ok.