trouble installing p-t after MySQL 5.6->5.7 upgrade

I am trying to upgrade MySQL from 5.6 to 5.7 using the yum repository. During my first attempt there was a conflict of dependencies, so I did

yum remove perl-DBD-MySQL

which also removed percona-toolkit. After seeing the upgrade succeed and MySQL restart successfully, I tried to reinstall percona-toolkit. Here are the results:

yum install percona-toolkit
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile

  • base: mirror.solarvps.com
  • epel: mirror.cogentco.com
  • extras: mirror.beyondhosting.net
  • updates: repo1.dal.innoscale.net
    Resolving Dependencies
    –> Running transaction check
    —> Package percona-toolkit.x86_64 0:3.0.4-1.el7 will be installed
    –> Processing Dependency: perl(DBD::mysql) >= 1.0 for package: percona-toolkit-3.0.4-1.el7.x86_64
    –> Running transaction check
    —> Package perl-DBD-MySQL.x86_64 0:4.023-5.el7 will be installed
    –> Processing Dependency: libmysqlclient.so.18(libmysqlclient_18)(64bit) for package: perl-DBD-MySQL-4.023-5.el7.x86_64
    –> Processing Dependency: libmysqlclient.so.18()(64bit) for package: perl-DBD-MySQL-4.023-5.el7.x86_64
    –> Running transaction check
    —> Package Percona-Server-shared-56.x86_64 0:5.6.36-rel82.1.el7 will be installed
    –> Finished Dependency Resolution

Dependencies Resolved

=========================================================================================================================
Package Arch Version Repository Size

Installing:
percona-toolkit x86_64 3.0.4-1.el7 percona-release-x86_64 4.8 M
Installing for dependencies:
Percona-Server-shared-56 x86_64 5.6.36-rel82.1.el7 percona-release-x86_64 619 k
perl-DBD-MySQL x86_64 4.023-5.el7 base 140 k

Transaction Summary

Install 1 Package (+2 Dependent packages)

Total size: 5.5 M
Installed size: 5.7 M
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
Running transaction test

Transaction check error:
file /etc/my.cnf from install of Percona-Server-shared-56-5.6.36-rel82.1.el7.x86_64 conflicts with file from package mysql-community-server-5.7.19-1.el7.x86_64

Error Summary

yum list installed|grep -i MySQL shows:

mysql-community-client.x86_64 5.7.19-1.el7 @mysql57-community
mysql-community-common.x86_64 5.7.19-1.el7 @mysql57-community
mysql-community-libs.x86_64 5.7.19-1.el7 @mysql57-community
mysql-community-server.x86_64 5.7.19-1.el7 @mysql57-community
mysql57-community-release.noarch el7-10

I’m not sure how to resolve the dependency or why the Transaction check error refers to /etc/my.cnf. Has anyone else experienced this?

Thanks,
Paul

Can you share the output of:

$ rpm -qa | egrep -i “percona|mysql”

I tried a few things and some googling, ended up installing mysql-community-libs-compat-5.7.19-1.el7.x86_64 with yum localinstall. After that percona-toolkit installed fine. RPM output below:

rpm -qa | egrep -i “percona|mysql”
mysql-community-libs-compat-5.7.19-1.el7.x86_64
percona-release-0.1-4.noarch
mysql-community-client-5.7.19-1.el7.x86_64
percona-toolkit-3.0.4-1.el7.x86_64
mysql-community-libs-5.7.19-1.el7.x86_64
perl-DBD-MySQL-4.023-5.el7.x86_64
mysql57-community-release-el7-10.noarch
mysql-community-server-5.7.19-1.el7.x86_64
mysql-community-common-5.7.19-1.el7.x86_64

Thanks for the response.

I’ve met the same issue trying to install percona-toolkit 3.0.5 along with percona-server-server-5.7
it looks like packages depends on conflicting mysql conector libraries
Is there a way to resolve it ?
Any info on fixes in further releases ?

I wasn’t able to reproduce this issue. Could you please inform on what OS did you face this issue?

You should install perl-DBD-MySQL in the following way:
yum install perl-DBD-MySQL --disablerepo percona-release*
and after that please try to install percona-toolkit

Looks like I’ve mixed up percona and mysql repositories and that caused the issue. Sorry for any trouble caused and thank you.