Sql_log_bin not supported in M-M-S replication on new pt-online-schema-change?

Hi Team,

We are facing some issue with updated version of pt-online-schema-change.

Issue : set sql_log_bin=OFF variable is not working with MMS (Master-Master-Slave) topology.

Below are details:
Mariadb Version : 10.3
Topology Used:
server4 server 1 server 2 server 3

Log slave update is enabled on server 1 & server 2
Replication format: row based.

Below is the final actual command

/usr/bin/pt-online-schema-change -uadmin --ask-pass -P3310 --nocheck-unique-key-change --progress=“time,10” -S/dbdata/mariadb-data/mariadb.sock --preserve-triggers --print --no-version-check --skip-check-slave-lag --execute --alter " " --set-vars=“sql_log_bin=OFF,max_statement_time=0” --max-load=“Threads_running=600” --critical-load=“Threads_running=450” --chunk-size=3000 D=property,t=whatsapp_tracking --execute

Please provide the solution, As per my observation, slave was down due to only pt trigger was replicating on slave side.

What exactly are you trying to do? Your --alter command is empty. What are you expecting here? Why are you trying to disable the binary logs (and by extension, disable replication)?