pt-table-checksum doesn't hunt un-synced records


I’m working on investigating a row in my slave replica which isn’t synced with the master replica row. I’m using that slave for SELECT only.

I ran pt-table-checksum on my master replica. It checked the table on master & slave both but it couldn’t hunt the difference. I can clearly see the column records in the row on both instances and there is difference in many columns, only the first auto-increment column holds identical data else all columns differ.

Is it because the pt-table-checksum works on the index not on the actuall row in table? I couldn’t find any option in pt-table-checksum manual to force it to skip the index and actually checksum the row in table.

When I do manually checksum the table in mysql I get a difference. Why pt-table-checksum failed in this situation and how can I make it work?


Can you provide commandline which you are running for checking checksum?


pt-table-checksum --user root --password myPassword --databases myDatabase --tables myTable --nocheck-replication-filters