PMM MySql 8.0.11 Instances Not Showing Graphs

Output of pmm-admin summary from client attached.

summary_lcormysqld01.transcontinental.ca_2019-01-22T08_28_39.tar.zip (51 KB)

baasp Thanks for logs! and Thanks Peter for Idea.
You right - https://github.com/prometheus/mysqld_exporter/issues/325#issuecomment-426798030 this is our case and
mysql_global_status_validate_password.dictionary_file_words_count 0

is wrong metrics name.

We did some fixes in our version and upstream https://github.com/prometheus/mysqld_exporter/pull/307 but later it was discovered that the problem is not 100% solved (https://github.com/prometheus/mysqld_exporter/pull/337)
The fix is not released in upstream.

baasp can you try a solution from https://github.com/prometheus/mysqld_exporter/issues/325#issuecomment-426798030? Meanwhile, we’ll prepare some code with patch from upstream fix

Yay, Thanks Roma and Peter.

The solution :

This problem apparently caused to pluggin:
mysql> SHOW VARIABLES LIKE ‘%dictionary%’;
±----------------------------------±------+
| Variable_name | Value |
±----------------------------------±------+
| validate_password.dictionary_file | |
±----------------------------------±------+
1 row in set (0.00 sec)

To resolve this problem, I disabled in the mysql:

mysql> SELECT @@plugin_dir;
±-------------------------+
| @@plugin_dir |
±-------------------------+
| /usr/lib64/mysql/plugin/ |
±-------------------------+
1 row in set (0.00 sec)

mysql> UNINSTALL COMPONENT ‘file://component_validate_password’;

Restart mysql and the mysqld_export connect to Prometheus.

Works.

However I cannot deploy that into production as we require enforcement of the password complexity.

When do you estimate a new release containing the patch will be published?

:slight_smile:

Hi baasp

We will be doing a 1.17.1 release on or around February 13, and it will include a fix for the issue you’re experiencing. If you’d like to track the issue, it is in our JIRA:
https://jira.percona.com/browse/PMM-3471
Thank you for your assistance while we identified and solved your request!

Hi,

I have deployed the 1.17.1 release but the issue is not release.

:frowning:

Peter

Resolved I meant to say.

Hi,

Can someone review this and let me know what to do to have the fix reviewed as it did not fix the issue.

Peter

I still have this problem. This is the server-client info (all centos 7):

  1. Server is docker “percona/pmm-server:2”
  2. Client 1 is mysql 5.7, everything works fine and I can see the graphs on the server.
  3. Client 2 is percona mysql 8.16 and none of the graphs shows up. Server reveals agents are connected, both 5.7 and 8. But for client 2 (mysql 8) I don’t get any graph. Not even client server OS info. I checked pmm-admin status on both clients. Both are connected and working file. Node exporter is running.

On both clients I have installed ppm2-client using yum. Interestingly I can not file any pmm log files on any of the client servers.
Any idea?

And I did create the pmm user with “mysql_native_password” option. An observation: on both clients I login using root account. Running “show full processlist” reveals 4 pmm users being connected on mysql 5.7, but on mysql 8.0 I see only one pmm connection.
It shows 1. pmm user can connact to both servers 2. There are more connections on mysql 5.7 than mysql 8.0, why?