pmm error 502

Hello,

For no apparent reason to me, I have 502 error that appears when I do a pmm-admin command on my pmm clients. (It worked great like 1 week ago)

I look a bit more quand it appears that “/managed/v1/version” return a bad gateway error 502.

Have you already met this problem ? I check on google and people talk about pmm managed service, but how can I restart it on my pmm server ?

I’m actually running pmm-server as a docker

Please find attached the logs of pmm-admin list on one of my client, and nginx error.log when I want to access to https://pmm-server:8080/managed/v1/version

Thanks for you help

Luc

nginx.error.txt (504 Bytes)

pmm-admin --verbose list.txt (1.66 KB)

The error log in nginx file stated Connection Refused, which i believe its because the service is not listen. I still don’t know why you use nginx ?. May i know the use of nginx ?. Is it separate machine with the pmm ?.

Sorry for replying this late, the nginx is the one included in the pmm docker. Since I use now pmm2 the problem is solved.