pmm-client syntax error

We are using v. 1.0.5 for both client and servers.
We are using mariadb 10.0.17 with sql_error_log plugins.

sql_error_log

2016-11-15 15:21:28 exporter[exporter] @ localhost [] ERROR 1064: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘NONBLOCKING’ at line 1 : SHOW SLAVE STATUS NONBLOCKING
2016-11-15 15:21:28 exporter[exporter] @ localhost [] ERROR 1064: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘NOLOCK’ at line 1 : SHOW SLAVE STATUS NOLOCK
2016-11-15 15:21:28 exporter[exporter] @ localhost [] ERROR 1193: Unknown system variable ‘query_response_time_stats’ : SELECT @@query_response_time_stats
2016-11-15 15:21:33 exporter[exporter] @ localhost [] ERROR 1064: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘NONBLOCKING’ at line 1 : SHOW SLAVE STATUS NONBLOCKING
2016-11-15 15:21:33 exporter[exporter] @ localhost [] ERROR 1064: You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near ‘NOLOCK’ at line 1 : SHOW SLAVE STATUS NOLOCK
2016-11-15 15:21:33 exporter[exporter] @ localhost [] ERROR 1193: Unknown system variable ‘query_response_time_stats’ : SELECT @@query_response_time_stats

Are there any ways to deactivate the data collector relating to the error?

Those errors are not normally visible because they are client-side errors.
Listed queries check various things to make exporter to work as efficient as possible.

You see those queries because of the plugin sql_error_log.
The errors do not affect performance and can be ignored.
There is no option to disable them because this is a part of the exporter functionality.