PMM client issue

Happy 2023 guys!
PMM is kicking my butt here. I have this following errors.I have checked some of your topics on PMM. I got the following error below when I did this

Pmm-admin add mysql mysql- - query-source=perfschema - - username =xxx - - password= xxxx .

Failed to get pmm server parameters from local pmm-agent:Post “ /local/status: dial tcp connect : connection refused
Please use - - server-url flag to specify pmm server url .

Please any idea

I think that means you haven’t yet registered this agent to the PMM server.

did you run this command:
pmm-admin config --server-insecure-tls --server-url=https://admin:<password>@<pmm-server>:<port>

1 Like

Yes I ran that already.

1 Like

Again, I tried to register the pmm-agent on the pmm server this was the error I got

Failed to register pmm-agent on PMM SERVER:
Node with name “” already exists. If you want override node, use - - force option.

1 Like

Hi Steve,

Node with name “[](” already exists. If you want override node, use --force option.

That means you have that registered already. Still, you can re-register again as follows:

pmm-admin config --server-insecure-tls --server-url=https://admin:<password>@<pmm-server>:<port> --force

Then check the status of pmm-admin as follows:
pmm-admin status

If it doesn’t work, then please check the debug info as follows:
pmm-admin config -server-insecure-tls --server-url=https://admin:<password>@<pmm-server>:<port> --debug

1 Like

Hello guys

I have tried debugging (- - debug option). That option prompted me to rerun the pmm-agent with config file option.
After closing my terminal or when I started a new terminal i always get pmm-agent not found.

Have seen a lot of people complaining with this installation and behavior. This is a great tool, but the installation is giving so much