PMM and Grafana not loading same in browser tab

We are run in Percona and Grafana on the same server…but it’s not working in the same browser. if try to run both tools it’s automatically logout anyone then we try to change 3000 to 5000 port number of grafana but still, the same issue occurred, is there any solutions or idea for this issue please let me know.

Thanks in Advance

Hello @Ajithkumar_ops,
It is an unsupported configuration to run PMM and Grafana on the same server. PMM uses Grafana internally (as you can tell) but the two tools are sharing cookie names/paths which will conflict. If you absolutely need to run them on the same machine, you will need an additional IP on this server and bind grafana to IP1 and PMM to IP2.

2 Likes

Hi @Ajithkumar_ops

The reason you couldn’t run both PMM and Grafana in the same browser is because both use the same name for the authentication cookie, which is grafana_session as of right now. Naturally, when you log out of one, the session becomes invalid in another.

One way to make PMM and Grafana coexist on the same server and share the same IP address is to change the name of the parameter responsible for setting the cookie name in /etc/grafana/grafana.ini. You’d want to do it in just one app, say in Grafana, so the two apps would no longer compete for the same cookie.

The parameter in queston is called login_cookie_name and it can be found in the [auth] section of grafana.ini.

Once your change is saved, don’t forget to uncomment the parameter. So you’d ultimately get to seeing something similar to this:

Finally, if you save the changes and restart the Grafana server, you should be able to launch both in the same browser! In case you want to verify your changes have been picked up by Grafana, you can go to the following url http://localhost:3000/admin/settings and check if the parameter has the new value you defined earlier, i.e.:

If we want to break down the steps, here they are:

  1. we assume you launched grafana like this:
    docker run -d --name=grafana -p 3000:3000 grafana/grafana
  2. copy grafana.ini to the host:
    docker cp grafana:/etc/grafana/grafana.ini grafana.ini
  3. uncomment & and set the value of the login_cookie_name parameter to my_grafana_session (see screenshot above)
  4. stop and remove grafana container:
    docker stop grafana && docker rm grafana
  5. start grafana anew while mounting the grafana.ini file as a volume:
    docker run -d --name=grafana -p 3000:3000 -v $(pwd)/grafana.ini:/etc/grafana/grafana.ini grafana/grafana

Please note we don’t recommend you change this parameter in PMM since we may choose to rename it later.

Please let us know if it works for you.
Alex

1 Like

Hi @atymchuk sir,
Thank you for your response, sir

it’s not working in the grafana server after changing that still grafana not loading sir. I checked the log file there having errors like,

Failed to load app dashboards logger=plugins error=open /var/lib/grafana/plugins/pmm-singlestat-panel/dist/dashboards/pmm-qan.json: no such file or directory

Note: Pmm Running inside docker and grafana running as a normal package.

1 Like

Looks like you PMM Server could not properly start. Hard to tell why without seeing how you started it. Could you drop the launch command here? Or maybe you can give any details relevant to understand the source of this issue?

Just want to shoot here a friendly link detailing how to start a PMM Server - Percona Monitoring and Management

1 Like

@atymchuk Thank you, Sir,

it’s working actually it’s taking so much time to load that both tool now it’s working fine sir…

@atymchuk and @matthewb thank’s lots sir for ur support…

2 Likes