pmm-admin config fails complaining about unidentified service

Please take a look at the following:

# pmm-admin --version
# pmm-admin config --server ...
Error restarting one of the services: "systemctl" failed: exit status 1
# systemctl list-units --failed
0 loaded units listed.

Some notes:

I already tried the --debug

  • parameter and I confirm all calls are answered with HTTP 200
  • There is no failed service
  • As much as I love random guessing, seeing the command that failed with status 1 would be useful :)

I could raise a bug if there is a bug here (other than the unhelpful error) but first I’d appreciate some guidance in finding out what is going wrong.


First, a dumb question, just in case :slight_smile: Are you trying with root? Your prompt (#) suggests you are, but just in case…

Secondly, did you check ? SELinux, maybe? What OS and systemd version are you using?

Please send exact commands being used, and I would go ahead and submit a bug so that we add more information to that error message in any case.

Hi Agustin,

Yes I was root.

That bug seems a bit different to me.

No SELinux. And the problem persisted after disabling apparmor.

The system was Ubuntu 20.04 on EC2. Note that I didn’t test on a fresh machine htough.

I randomly discovered that runningpmm-admin repair twice solved the problem. These things happened consistently, even after removing and re-installing PMM Client.

It remains a total mystery for me, but I didn’t have more problems so I’m not spending more time on it.