Plugins not compatabile with cacti 0.8.8c?

Hi Guy’s.

I’m running cacti 0.8.8c on Centos and tried installing the latest plugins but was met with the following error:

rpm -i percona-cacti-templates-1.1.4-1.noarch.rpm
warning: percona-cacti-templates-1.1.4-1.noarch.rpm: Header V4 DSA/SHA1 Signature, key ID cd2efd2a: NOKEY
error: Failed dependencies:
cacti >= 0.8.6 is needed by percona-cacti-templates-1.1.4-1.noarch

Is there a compatible version around?

Thanks.

Hi,
You probably installed Cacti from source and not from an rpm file. You can verify it by running: rpm -qa|grep cacti
If no output is displayed, then you installed Cacti from source.

If this is the case, I would suggest to download http://www.percona.com/downloads/percona-monitoring-plugins/1.1.4/percona-monitoring-plugins-1.1.4.tar.gz and extract the cacti template from there instead of installing percona-cacti-templates-1.1.4-1.noarch.rpm

Or you can try rpm -i --nodeps if you know you have Cacti installed from sources but if you go packages way I would recommend using Cacti packaged version as well.

Thank guy’s, running with nodeps worked a treat. I’ve tested a connection to my nginx servers using ss_get_by_ssh.php. Are there any guides on how to implement this into cacti noo so i can’t start producing graphs?

http://www.percona.com/doc/percona-monitoring-plugins/1.1/cacti/ssh-based-templates.html
than http://www.percona.com/doc/percona-monitoring-plugins/1.1/cacti/nginx-templates.html

THanks. I’ve installed the plugins correctly on my server but i’m unsure how to create the graphs from these?

Actually guy’s, i’ve got the template for nginx installed ok into cacti and i’ve copied the ss_get_by_ssh.php script to the same server. How do i embed the SSH password into the file and also my graphs are showing -nan… Appreciate any help as i’m sure i need the password embedded to get this working right?

Hi guy’s. I’ve imported the template fine, setup passphraseless keys for ssh access from cacto to my nginx instance. Tested ok. I’ve created my graphs but i’m not getting any data back? I’m getting a -nan result. Also, is there a way to check that the template is using the ss_get_by_ssh.php correctly and pointing to it?