phpMyAdmin wants me to upgrade

Hi everyone,

I’ve installed Percona Server for MySQL (5.7.22-22) on a fresh Ubuntu 16.04 LTS. I used followed the instructions and everything seems to be fine. The MySQL server is running and I’ve imported a database and it’s all good.

But then I wanted to install phpMyAdmin and I used apt-get install phpmyadmin and got version 4.5.4.1.

The thing is when I go to the User Accounts tab in phpMyAdmin I get the message:

This is not a production environment yet so I tried the mysql_upgrade command but it didn’t change anything.

Anyone experienced the same and have a solution? Thank you!

I found a way to fix this and will share it with you guys just in case I’m not the only one:
https://bugs.launchpad.net/ubuntu/+s…n/+bug/1693778

So a small change in the file server_privileges.lib.php solved the problem.

Hello espenlg, THANK YOU! It will likely help someone else in the future.

We took a look and it seems that the latest PhP MyAdmin source includes the fix, but it’s good for anyone who is stuck for now with an old version. Thanks again!

Mas como faço essa correção do Bug? Entrei nesse link aí mas não informa como corrige.

Mas como faz para corrigir o bug? Entrei no link mas não informa como faz a correção.

Translate:
But how do I fix this bug? I entered this link there but it does not report how it corrects.

Hello AntunesNeto if you aren’t in the latest version of phpMyAdmin it looks like the poster is saying you need to replace some code in the server_privileges.lib.php file of phpMyAdmin … the actual code is at the ‘patch’ link, the second entry in that bug report.

Do, though, make sure that you a have a back up of the current file before you do anything in case you need to revert.