Percona XtraDB Cluster 8.x Installation

Hi anyone can help me?

i tried to install Percona XtraDB Cluster.

im using centos 8.

previously already install mariadb,

already remove mariadb.

command im using,

$ sudo yum install
$ sudo percona-release enable-only pxc-80 release
$ sudo percona-release enable tools release
$ sudo yum install percona-xtradb-cluster

but im having problem to install.


Appreciate anyone can help me.

Thank you.

hi @hafizhasssan

I was able to install everything correctly using commands provided by you.

I assume that the main issue you are also install MarriaDB packages(I see it in yum output) and yes there might be a conflict.

So if you have installed MariaDB on your system it would be better to remove it firstly(surely prepare backup for database) and then install Percona-XtraDB-Cluster.

hi @Evgeniy_Patlan thanks for your response.

i already remove old mariadb.

yet the error same…

@hafizhasssan could you please execute “yum list installed | grep -i mariadb” and provide the output. So I could check



here. nothing appear.

@hafizhasssan I still can’t reproduce this issue. Maybe you have enable mariadb’s repo and you are trying to install something else together with percona-xtradb-cluster?

So what I suggest doing.

1 check if the files are still on the system

ls -la /etc/my.cnf

if file exists - rpm -qf /etc/my.cnf

ls -la /usr/lib64/mysql/plugin/

if file exists - rpm-qf /usr/lib64/mysql/plugin/

Please provide me with the results.

The next step I would suggest disabling MariaDB’s repo and trying to install percona-xtradb-cluster


here are the result.

few hour ago i remembered i saw mariadb repo available also.

do i need to disable?

@hafizhasssan yes please disable it and try to install percona-xtradb-cluster

@Evgeniy_Patlan i dont know how to disable.

@hafizhasssan there are a few ways how to do this

First of all you need to get it’s name yum repolist should help you

I assume you will get the following

mariadb-main                                     MariaDB Server
mariadb-maxscale                                 MariaDB MaxScale 
mariadb-tools                                    MariaDB Tools

To disable you can do the following

modify /etc/yum.repos.d/mariadb.repo and set enabled = 0
sudo sed -i 's:enabled = 1:enabled = 1:g' /etc/yum.repos.d/mariadb.repo

yum-config-manager --disable mariadb-main 
yum-config-manager --disable mariadb-maxscale
yum-config-manager --disable mariadb-tools


sudo yum install --disablerepo=mariadb-main percona-xtradb-cluster

Additionally I would suggest running yum clean all before running yum install

is this correct to install Percona XtraDB Cluster? @Evgeniy_Patlan

thank you so much @Evgeniy_Patlan ,

success install

@hafizhasssan Glad to hear that you were able to install successfully. If you have any other questions - please create new topics :slight_smile:

@Evgeniy_Patlan :slight_smile: tq. ok mate…