Install issue .. No package percona-xtradb-cluster available (Centos7)

Folks,
I’m trying to install PXC-80 on Centos7.6 VMs. I’m getting an issue finding percona-xtradb-cluster packages on the final yum install. It seems to me that the repo is empty or has some error in play that is not listing the packages.

I followed the online instructions (https://www.percona.com/doc/percona-…html#commands) which list the following set of commands:


$ sudo yum install https://repo.percona.com/yum/percona-release-latest.noarch.rpm
$ sudo percona-release enable-only pxc-80 release
$ sudo percona-release enable tools-release
$ sudo yum install percona-xtradb-cluster 

Of those above commands, the 3rd seems to have a typo. Should be “enable tools release” with the dash removed between tools and release. If you enter as written it will fail. Once you get beyond that, then the yum install fails to find a matching package.

Below is the exact set of commands I run and the results. I’m showing it first to indicate that the only percona package installed is the yum repo. Then I enable the pxc-80 release, tools and finally try to install the “percona-xtradb-cluster” package.

[root@localhost ~]# rpm -qa | grep -i percona
percona-release-1.0-13.noarch
[root@localhost ~]# percona-release enable-only pxc-80 release
* Disabling all Percona Repositories
* Enabling the Percona XtraDB Cluster 8.0 repository
<*> All done!
[root&#64;localhost ~]# percona-release enable tools release
* Enabling the Percona Tools repository
<*> All done!
[root&#64;localhost ~]# yum install percona-xtradb-cluster
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: ftp.heanet.ie
* centos-sclo-rh: ftp.heanet.ie
* centos-sclo-sclo: ftp.heanet.ie
* epel: mirrors.coreix.net
* extras: ftp.heanet.ie
* updates: ftp.heanet.ie
pxc-80-release-noarch | 2.9 kB 00:00:00 
pxc-80-release-x86_64 | 2.9 kB 00:00:00 
tools-release-noarch | 2.9 kB 00:00:00 
tools-release-x86_64 | 2.9 kB 00:00:00 
No package percona-xtradb-cluster available.
Error: Nothing to do


I was able to install standard ps-80 (Percona Server) but for this evaluation I need to work with the Xtradb-Cluster package set.

I can also list repos for stats on package counts and we see that the XtraDB Cluster repo lists no packages present for either pxc-80 repo

[root&#64;localhost ~]# yum repolist
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* base: ftp.heanet.ie
* centos-sclo-rh: ftp.heanet.ie
* centos-sclo-sclo: ftp.heanet.ie
* epel: www.mirrorservice.org
* extras: ftp.heanet.ie
* updates: ftp.heanet.ie
repo id repo name status
base/7/x86_64 CentOS-7 - Base 10,019
centos-sclo-rh/x86_64 CentOS-7 - SCLo rh 8,472
centos-sclo-sclo/x86_64 CentOS-7 - SCLo sclo 801
epel/x86_64 Extra Packages for Enterprise Linux 7 - x86_64 13,383
extras/7/x86_64 CentOS-7 - Extras 435
pxc-80-release-noarch/7 Percona XtraDB Cluster 8.0 release/noarch YUM repository 0
pxc-80-release-x86_64/7 Percona XtraDB Cluster 8.0 release/x86_64 YUM repository 0
tools-release-noarch/7 Percona Tools release/noarch YUM repository 0
tools-release-x86_64/7 Percona Tools release/x86_64 YUM repository 59
updates/7/x86_64 CentOS-7 - Updates 2,500
repolist: 35,669
[root&#64;localhost ~]# 

Hoping someone can confirm seeing the same thing. I probably could go a tarball install but would much rather use RPMs and yum.

Any help appreciated.

Perconal XtraDB Cluster 8 is not released yet.
You can install Perconal XtraDB Cluster 5.7 now

@“steven Lin” I am facing the same problem while installing. But Percona document clearly explain about installation. I am confused, can you please tell me whether it has been released?

@Gandharva Percona-XtraDB-Cluster-80 is not released yet. Only experimental release is available in experimental repos.
Please see https://www.percona.com/blog/2020/03/19/help-drive-the-future-of-percona-xtradb-cluster/

I ran into this exact same snag but for Ubuntu. You just need to use “experimental” or “testing” instead of “release”. More on that here: https://www.percona.com/doc/percona-repo-config/percona-release.html#example-all-steps-for-installing-a-specific-percona-product
Anyway, so it’s now currently in “testing” so you would do this:

sudo percona-release enable-only pxc-80 testing<br>