Percona XtraDB 8.0.33-25-1 2nd Node cannot join the cluster

To get started i didn’t experience this issue with Percona Galera XtraDB 8.0.26, I’m only see this in 8.0.33 Below my server specs

I have 3 Percona Galera XtraDB Cluster with 3 nodes

Percona Galera XtraDB version :

# dpkg --list | grep -i percona
ii  percona-xtrabackup-80                 8.0.34-29-1.focal                 amd64        Open source backup tool for InnoDB and XtraDB
ii  percona-xtradb-cluster-client         1:8.0.33-25-1.focal               amd64        Percona XtraDB Cluster database client binaries
ii  percona-xtradb-cluster-common         1:8.0.33-25-1.focal               amd64        Percona XtraDB Cluster database common files (e.g. /etc/mysql/my.cnf)
ii  percona-xtradb-cluster-server         1:8.0.33-25-1.focal               amd64        Percona XtraDB Cluster database server binaries

OS Version : Ubuntu 20 bullseye/sid

When either miniongal00[2,3]
is trying to join the cluster if failed with the same error message on the joiner

2023-10-16T23:40:02.165245Z 0 [Warning] [MY-000000] [WSREP-SST] Found a stale sst_in_progress file: /var/lib/mysql-miniongal002/myisam/data//sst_in_progress
2023-10-16T23:40:02.186978Z 0 [ERROR] [MY-000000] [WSREP] Failed to read 'ready <addr>' from: wsrep_sst_xtrabackup-v2 --role 'joiner' --address '' --datadir '/var/lib/mysql-miniongal002/myisam/data/' --basedir '/usr/' --plugindir '/usr/lib64/mysql/plugin/' --defaults-file '/var/lib/mysql-miniongal002/my.cnf-master' --defaults-group-suffix '' --parent '3519652' --mysqld-version '8.0.33-25.1'  --binlog '/var/lib/mysql-miniongal002/binlogs/miniongal002-bin'
        Read: '(null)'
2023-10-16T23:40:02.187023Z 0 [ERROR] [MY-000000] [WSREP] Process completed with error: wsrep_sst_xtrabackup-v2 --role 'joiner' --address '' --datadir '/var/lib/mysql-miniongal002/myisam/data/' --basedir '/usr/' --plugindir '/usr/lib64/mysql/plugin/' --defaults-file '/var/lib/mysql-miniongal002/my.cnf-master' --defaults-group-suffix '' --parent '3519652' --mysqld-version '8.0.33-25.1'  --binlog '/var/lib/mysql-miniongal002/binlogs/miniongal002-bin' : 1 (Operation not permitted)
2023-10-16T23:40:02.187078Z 1 [ERROR] [MY-000000] [WSREP] Failed to prepare for 'xtrabackup-v2' SST. Unrecoverable.
2023-10-16T23:40:02.187156Z 1 [ERROR] [MY-000000] [Galera] SST request callback failed. This is unrecoverable, restart required.
2023-10-16T23:40:02.187165Z 1 [Note] [MY-000000] [Galera] ReplicatorSMM::abort()

I attached the full log of the donor miniongal001 and the receiver miniongal002 showing the Error message above

I also attached the config file for the node

10-24-2023_donor-error.log (14.8 KB)
10-24-2023_receiver-error.log (251.2 KB)
my.log (1.5 KB)

FYI apparmor is enabled and we have the necessary rule in place in 8.0.26 and it’s working fine but once 8.0.33 is installed SST is not working. i stopped the service and disabled apparmor but still the same result.

Did you bootstrap miniogal001 before you triggered SST? How did you start it?


You have set the transfer format as nc. Can you make sure that the utility is available?