Node: Not Joining the Cluster

Hi All,
Facing below issue while joining new Node into existing cluster.
Tried mutiple ways to start SST but seeing the same error from longtime and not able to join the Node into the existing cluster …

Seeking any help/Fix on this

2023-07-08 2 [Note] [MY-000000] [Galera] IST receiver addr using tcp://Hostname:4568
2023-07-08T20:41:04.627772+05:30 2 [Note] [MY-000000] [Galera] Prepared IST receiver for 0-582484, listening at: tcp://Hostname:4568
2023-07-08T20:41:04.629059+05:30 0 [Note] [MY-000000] [Galera] Member 2.2 (IVS_TXN_SDC_5469) requested state transfer from ‘any’. Selected 0.2 (IVS_TXN_SDC_5466)(SYNCED) as donor.
2023-07-08T20:41:04.629136+05:30 0 [Note] [MY-000000] [Galera] Shifting PRIMARY → JOINER (TO: 582484)
2023-07-08T20:41:04.629196+05:30 2 [Note] [MY-000000] [Galera] Requesting state transfer: success, donor: 0
2023-07-08T20:41:04.629218+05:30 2 [Note] [MY-000000] [Galera] Resetting GCache seqno map due to different histories.
2023-07-08T20:41:04.629235+05:30 2 [Note] [MY-000000] [Galera] GCache history reset: 00000000-0000-0000-0000-000000000000:0 → 5e01aac5-1c27-11ee-a446-

2023-07-08T20:41:05.953631+05:30 0 [Note] [MY-000000] [Galera] (a70ae9fa-96ba, ‘tcp://’) turning message relay requesting off
2023-07-08T20:41:07.287199+05:30 0 [Note] [MY-000000] [WSREP-SST] Proceeding with SST…
2023-07-08T20:41:07.336548+05:30 0 [Note] [MY-000000] [WSREP-SST] …Waiting for SST streaming to complete!

******************* FATAL ERROR **********************
2023-07-08T20:43:18.140213+05:30 0 [ERROR] [MY-000000] [WSREP-SST] xtrabackup_checkpoints missing. xtrabackup/SST failed on DONOR. Check DONOR log

2023-07-08T20:43:18.140280+05:30 0 [ERROR] [MY-000000] [WSREP-SST] ******************************************************
2023-07-08T20:43:18.140554+05:30 0 [ERROR] [MY-000000] [WSREP-SST] Cleanup after exit with status:2

2023-07-08T20:43:18.172470+05:30 0 [ERROR] [MY-000000] [WSREP] Process completed with error: wsrep_sst_xtrabackup-v2 --role ‘joiner’ --address ‘Hostname’ --datadir ‘/data/mysqldata/mysql/’ --basedir ‘/usr/’ --plugindir ‘/usr/lib/mysql/plugin/’ --defaults-file ‘/etc/mysql/my.cnf’ --defaults-group-suffix ‘’ --parent ‘83771’ --mysqld-version ‘8.0.32-24.1’ ‘’ : 2 (No such file or directory)

2023-07-08T20:43:18.172583+05:30 0 [ERROR] [MY-000000] [WSREP] Failed to read uuid:seqno from joiner script.

2023-07-08T20:43:18.172614+05:30 0 [ERROR] [MY-000000] [WSREP] SST script aborted with error 2 (No such file or directory)

2023-07-08T20:43:18.172874+05:30 3 [Note] [MY-000000] [Galera] Processing SST received
2023-07-08T20:43:18.172967+05:30 3 [Note] [MY-000000] [Galera] SST received: 00000000-0000-0000-0000-000000000000:-1
2023-07-08T20:43:18.173013+05:30 3 [System] [MY-000000] [WSREP] SST completed
2023-07-08T20:43:18.173043+05:30 2 [Note] [MY-000000] [Galera] str_proto_ver_: 3 sst_seqno_: -1 cc_seqno: 582484 req->ist_len(): 71
2023-07-08T20:43:18.173089+05:30 2 [ERROR] [MY-000000] [Galera] Application received wrong state:
Received: 00000000-0000-0000-0000-000000000000
Required: 5e01aac5-1c27-11ee-a446-da7dc699c587
2023-07-08T20:43:18.173110+05:30 2 [ERROR] [MY-000000] [Galera] Application state transfer failed. This is unrecoverable condition, restart required.
2023-07-08T20:43:18.173128+05:30 2 [Note] [MY-000000] [Galera] ReplicatorSMM::abort()
2023-07-08T20:43:18.173149+05:30 2 [Note] [MY-000000] [Galera] Closing send monitor…
2023-07-08T20:43:18.173167+05:30 2 [Note] [MY-000000] [Galera] Closed send monitor.
2023-07-08T20:43:18.173187+05:30 2 [Note] [MY-000000] [Galera] gcomm: terminating thread
2023-07-08T20:43:18.173214+05:30 2 [Note] [MY-000000] [Galera] gcomm: joining thread
2023-07-08T20:43:18.173371+05:30 2 [Note] [MY-000000] [Galera] gcomm: closing backend
2023-07-08T20:43:18.174000+05:30 2 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node
view (view_id(NON_PRIM,68ec5465-a81f,9)
memb {
joined {


left {


partitioned {





2023-07-08T20:43:18.174061+05:30 2 [Note] [MY-000000] [Galera] PC protocol downgrade 1 → 0
2023-07-08T20:43:18.174082+05:30 2 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node
view ((empty))
2023-07-08T20:43:18.174251+05:30 2 [Note] [MY-000000] [Galera] gcomm: closed
2023-07-08T20:43:18.174303+05:30 0 [Note] [MY-000000] [Galera] New COMPONENT: primary = no, bootstrap = no, my_idx = 0, memb_num = 1
2023-07-08T20:43:18.174362+05:30 0 [Note] [MY-000000] [Galera] Flow-control interval: [100, 100]
2023-07-08T20:43:18.174380+05:30 0 [Note] [MY-000000] [Galera] Received NON-PRIMARY.
2023-07-08T20:43:18.174389+05:30 0 [Note] [MY-000000] [Galera] Shifting JOINER → OPEN (TO: 582484)
2023-07-08T20:43:18.174400+05:30 0 [Note] [MY-000000] [Galera] New SELF-LEAVE.
2023-07-08T20:43:18.174429+05:30 0 [Note] [MY-000000] [Galera] Flow-control interval: [0, 0]
2023-07-08T20:43:18.174442+05:30 0 [Note] [MY-000000] [Galera] Received SELF-LEAVE. Closing connection.
2023-07-08T20:43:18.174450+05:30 0 [Note] [MY-000000] [Galera] Shifting OPEN → CLOSED (TO: 582484)
2023-07-08T20:43:18.174458+05:30 0 [Note] [MY-000000] [Galera] RECV thread exiting 0: Success
2023-07-08T20:43:18.174590+05:30 2 [Note] [MY-000000] [Galera] recv_thread() joined.
2023-07-08T20:43:18.174700+05:30 2 [Note] [MY-000000] [Galera] Closing replication queue.
2023-07-08T20:43:18.174776+05:30 2 [Note] [MY-000000] [Galera] Closing slave action queue.
2023-07-08T20:43:18.174835+05:30 2 [Note] [MY-000000] [Galera] /usr/sbin/mysqld: Terminated.
2023-07-08T20:43:18.174876+05:30 2 [Note] [MY-000000] [WSREP] Initiating SST cancellation
Job for mysql.service failed because a fatal signal was delivered to the control process.
See “systemctl status mysql.service” and “journalctl -xe” for details.

2023-07-08T20:44:11.764036+05:30 0 [ERROR] [MY-000000] [WSREP-SST] ------------ innobackup.backup.log (END) ------------
2023-07-08T20:44:11.764079+05:30 0 [ERROR] [MY-000000] [WSREP-SST] ******************************************************
2023-07-08T20:44:11.764164+05:30 0 [ERROR] [MY-000000] [WSREP-SST] Cleanup after exit with status:22
2023-07-08T20:44:11.852241+05:30 0 [ERROR] [MY-000000] [WSREP] Process completed with error: wsrep_sst_xtrabackup-v2 --role ‘donor’ --address ‘’ --socket ‘/var/run/mysqld/mysqld.sock’ --datadir ‘/data/mysqldata/mysql/’ --basedir ‘/usr/’ --plugindir ‘/usr/lib/mysql/plugin/’ --defaults-file ‘/etc/mysql/my.cnf’ --defaults-group-suffix ‘’ --mysqld-version ‘8.0.32-24.1’ ‘’ --gtid ‘5e01aac5-1c27-11ee-a446-da7dc699c587:582484’ : 22 (Invalid argument)
2023-07-08T20:44:11.857363+05:30 0 [Note] [MY-000000] [Galera] SST sending failed: -22
2023-07-08T20:44:11.857460+05:30 0 [Note] [MY-000000] [WSREP] Server status change donor → joined
2023-07-08T20:44:11.857530+05:30 0 [Note] [MY-000000] [WSREP] wsrep_notify_cmd is not defined, skipping notification.
2023-07-08T20:44:11.857661+05:30 0 [ERROR] [MY-000000] [WSREP] Command did not run: wsrep_sst_xtrabackup-v2 --role ‘donor’ --address’ --socket ‘/var/run/mysqld/mysqld.sock’ --datadir ‘/data/mysqldata/mysql/’ --basedir ‘/usr/’ --plugindir ‘/usr/lib/mysql/plugin/’ --defaults-file ‘/etc/mysql/my.cnf’ --defaults-group-suffix ‘’ --mysqld-version ‘8.0.32-24.1’ ‘’ --gtid ‘5e01aac5-1c27-11ee-a446-da7dc699c587:582484’

This looks to me like you have not setup host1 and host2 correctly to start the cluster.

Welcome to Percona Community @KishoreTulluri,

To start debugging, I’d read through the log and try answering issues. So, I see this:

2023-07-08T20:43:18.140213+05:30 0 [ERROR] [MY-000000] [WSREP-SST] xtrabackup_checkpoints missing. xtrabackup/SST failed on DONOR. Check DONOR log

I’d go ahead and check the donor node for backup log in datadir for what is causing it to fail.