Percona on CENTOS 5.8

Dear all,

I install Percona 5.5 from yum command. And there is not any my.cnf by default, we known it.

After install service mysql start normal.

But when I add my customize my.cnf to /etc or /etc/mysql, service mysql doesn’t start.

This is the error:

service mysql start [FAILED]
Starting MySQL (Percona Server).The server quit without update PID file (/var/lib/mysql/

This is my.cnf content:

[mysqld]user = mysqldefault-storage-engine = InnoDBsocket = /var/lib/mysql/mysql.sock# pid_file = /var/lib/mysql/data/mysql.pidskip-name-resolvetransaction_isolation = READ-UNCOMMITTEDinnodb_buffer_pool_size = 800Minnodb_log_file_size = 200Minnodb_additional_mem_pool_size = 20Minnodb_file_per_table = 1innodb_log_buffer_size = 8Minnodb_flush_log_at_trx_commit = 1innodb_thread_concurrency = 4innodb_flush_method=O_DIRECTinnodb_read_io_threads = 16innodb_write_io_threads = 16innodb_io_capacity=500innodb_lock_wait_timeout = 120innodb_data_file_path = ibdata1:100M;ibdata2:100M:autoextendlog_error = /var/log/mysqld/mysql-error.loglog_queries_not_using_indexes = 1slow_query_log = 1slow_query_log_file = /var/log/mysqld/slow.log

Am I wrong when create my.cnf in /etc or /etc/mysql?


If delete my.cnf file, the service mysql start normally.

I had turned off SELinux, but there’s no change.

How can I use my custom my.cnf?

What does the error log say ?

There is nothing in error log. The log I checked is from: /var/lib/mysql/c01.err (my linux name is: c01).

I tried to delete the error log file before starting service with my custom /etc/my.cnf. But error log file was not created when starting service error.

My percona server is fresh install on a fresh linux too. I tried on a VirtualBox, and this is a dedicated machine for percona, it runs percona only without any thing.