CentOS 5 and Percona Startup (and my.cnf feedback request)

We’ve just received two new Cisco C210 servers and so I decided to install CentOS 5 - clean install.

When I install MySQL 5.1 (or 5.5) and try to start it, it won’t work unless I use the sudo command. Any idea why?

[root@tigdb2 mysql]# /etc/init.d/mysql start
Starting MySQL (Percona Server). ERROR! Manager of pid-file quit without updating file.
[root@tigdb2 mysql]# sudo /bin/sh /etc/init.d/mysql start
Starting MySQL (Percona Server)… SUCCESS!
[root@tigdb2 mysql]#

Also, I’d appreciate any feedback on this my.cnf - we have 64 GB of RAM:

datadir = /var/lib/mysql

port = 3306
socket = /home/mysql/mysql.sock
pid-file = /home/mysql/mysql.pid
sync_binlog = 1
key_buffer = 400M
max_allowed_packet = 8M
table_cache = 2500
sort_buffer_size = 3M
read_buffer_size = 2M
read_rnd_buffer_size = 6M
myisam_sort_buffer_size = 50M
thread_cache = 40
query_cache_size = 512M
ft_min_word_len = 3
tmp_table_size = 512M
max_heap_table_size = 128M
query_cache_limit = 2M
query_prealloc_size = 24576
max_binlog_size = 128000000
max_connect_errors = 10000
wait_timeout = 1200
expire_logs_days = 10

slow-query-log = 1
log-warnings = 0
long_query_time = 10


thread_concurrency = 4
max_connections = 500

server_id = 5
log-bin = tigdb3-bin
relay-log = tigdb3-relay-bin
auto_increment_increment = 2
auto_increment_offset = 1

innodb_buffer_pool_size = 16384M
innodb_additional_mem_pool_size = 20M
innodb_log_file_size = 1024M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 0

max_allowed_packet = 16M

Oops, I actually meant to reference CentOS 6, not 5. Any ideas on this issue?

check the permissions of /home/mysql/mysql.pid and /home/mysql and make sure the mysql user can write to mysql.pid.

Yes, both are owned by the mysql user/group. (and writable by both)

Maybe there’s more info in the MySQL log files, but please also check your system log files (selinux perhaps?)

MySQL logs don’t show anything :frowning:

I checked the two selinux options related to MySQL and have disabled both. Any specific selinux instructions for a setting change to allow MySQL to start? I’m not too familiar with SELinux.

Thank you!

I’ve noticed similar before on my servers.

Your first start that ‘failed’, may not have actually failed. There is a timeout that might have happened first (wait a bit and then try and connect to MySQL / ps aux for it).

Please, run “ausearch -c mysqld -sv no” and post output here

Attach your init script here. I’ll compare with my

Here it is. Thank you!