Percona MySQL server Installation Issues with Rocky Linux 9

While trying to install the percona-release-latest.noarch.rpm, I keep running into the following error.

Running transaction
  Preparing        :                                                                                                                                                                                         
  Installing       : percona-release-1.0-27.noarch                                                                                                                                                           
  Running scriptlet: percona-release-1.0-27.noarch                                                                                                                                                           
error: can't create transaction lock on /var/lib/rpm/.rpm.lock (Resource temporarily unavailable)
error: /etc/pki/rpm-gpg/RPM-GPG-KEY-Percona: key 1 import failed.

I tried running the command as root and even tried to fix the permission on the .rpm.lock file but it doesn’t seem to work.

Hello Nspeaks,
I have tried this on my test env, and i resolved it by
sudo rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-Percona
afterwards i verified that it’s installed correctly

[root@ip-172-31-81-170 rocky]# sudo yum install -y
Percona Original release/x86_64 YUM repository                                                                                                                       2.0 MB/s | 1.6 MB     00:00
Percona Original release/noarch YUM repository                                                                                                                       973  B/s | 257  B     00:00
Percona Release release/noarch YUM repository                                                                                                                        6.7 kB/s | 1.8 kB     00:00
percona-release-latest.noarch.rpm                                                                                                                                     69 kB/s |  20 kB     00:00
Package percona-release-1.0-27.noarch is already installed.
Dependencies resolved.
Nothing to do.
[root@ip-172-31-81-170 rocky]#

enabled repository for ps8

[root@ip-172-31-81-170 rocky]# percona-release setup ps80
* Disabling all Percona Repositories
On Red Hat 8 systems it is needed to disable the following DNF module(s): mysql  to install Percona-Server
Do you want to disable it? [y/N] y
Disabling dnf module...
Last metadata expiration check: 0:01:47 ago on Wed Nov 29 13:39:12 2023.
Unable to resolve argument mysql
Error: Problems in request:
missing groups or modules: mysql
DNF mysql module was disabled
* Enabling the Percona Server 8.0 repository
* Enabling the Percona Tools repository
<*> All done!

And installation of the percona server 8 completed without issues:

[root@ip-172-31-81-170 rocky]# systemctl start mysql
[root@ip-172-31-81-170 rocky]# mysql
ERROR 1045 (28000): Access denied for user 'root'@'localhost' (using password: NO)
[root@ip-172-31-81-170 rocky]# systemctl status mysql
● mysqld.service - MySQL Server
     Loaded: loaded (/usr/lib/systemd/system/mysqld.service; enabled; preset: disabled)
     Active: active (running) since Wed 2023-11-29 13:44:30 UTC; 11s ago
       Docs: man:mysqld(8)
    Process: 27598 ExecStartPre=/usr/bin/mysqld_pre_systemd (code=exited, status=0/SUCCESS)
   Main PID: 27672 (mysqld)
     Status: "Server is operational"
      Tasks: 40 (limit: 22859)
     Memory: 463.0M
        CPU: 7.511s
     CGroup: /system.slice/mysqld.service
             └─27672 /usr/sbin/mysqld

Nov 29 13:44:17 ip-172-31-81-170.ec2.internal systemd[1]: Starting MySQL Server...
Nov 29 13:44:30 ip-172-31-81-170.ec2.internal systemd[1]: Started MySQL Server.
[root@ip-172-31-81-170 rocky]# cat /var/log/mysqld.log | grep -i pass
2023-11-29T13:44:24.578257Z 6 [Note] [MY-010454] [Server] A temporary password is generated for root@localhost: rN..2CaFFqdJ
[root@ip-172-31-81-170 rocky]# mysql -u root -p
Enter password:
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 9
Server version: 8.0.34-26

Copyright (c) 2009-2023 Percona LLC and/or its affiliates
Copyright (c) 2000, 2023, Oracle and/or its affiliates.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.


Please check and let us know if it’s helps.

Denis Subbota.
Managed Services, Percona.