option -e for resolution and retention configuration

pmm-server version: percona/pmm-server:1.0.4
Servers version: 5.6.32-78.1-log Percona Server (GPL), Release 78.1, Revision 4c779b7
pmm-client version: 1.0.4

When we create pmm-server with the same command of the tutorial, we see the data in the Grafana interface.

Instead when we create pmm-server and add -e option for the METRICS_RESOLUTION configuration, we don’t see the data in the Grafana interface but only a red “!” in the top-left corner of each graph and a red pop-up warning with the follow message: Dashboard init failed Template variables could not be initialized: Internal Server Error

The commands tested are:
[]docker run -d -p 8080:80 -e METRICS_RETENTION=192h --volumes-from pmm-data --name pmm-server --restart always percona/pmm-server:1.0.4 # it works
]docker run -d -p 8080:80 -e METRICS_RESOLUTION=60s --volumes-from pmm-data --name pmm-server --restart always percona/pmm-server:1.0.4 # there is the problem
How to can we change the METRICS_RESOLUTION option?

The values can be between 1s(default) and 5s. If you set a higher value, Prometheus will not start.

That’s why your Grafana stop working. You can bump minimal resolution from 1s to 5s only via this env variable.